Status

RESOLVED FIXED
3 years ago
7 months ago

People

(Reporter: jlund, Assigned: coop)

Tracking

Details

(Reporter)

Description

3 years ago
12:01:02 <gps> jlund: `hg branches` and `hg tags` could spin CPU for a *long* time on old Mercurial versions. mostly fixed in 3.4+
12:01:52 <gps> strace likely won't report anything because it all CPU inside Python that doesn't perform any system calls monitored by strace by default
12:02:00 <gps> likely only malloc, etc
12:02:41 <jlund> though I'm all on board with upgrading hg, I can't do that to unblock this current release in flight
12:05:19 <jlund> gps: hwine: any other ideas?
12:05:53 <jlund> can we clean up the repo? I'm wondering if it has 1 too many branches for our old hg version to handle :)
12:06:54 <hwine-coffee> jlund: have you tried the workaround from last time of catting the fd?
12:07:25 <jlund> not yet. I am assuming this will happen for every release...
12:08:01 <gps> you could upgrade mercurial to 3.6.1 and get all the bug fixes and performance improvements
12:08:10 <jlund> but I can try that, and file a bug to upgrade to new hg
12:16:06 <gps> i'll be honest - i find it difficult to help debug possible mercurial issues when you are running a release that's so old
Wait a day or 2 and 3.6.2 should be released. You should upgrade to that.
3.6.2 is released.
(Assignee)

Comment 3

3 years ago
Pushing forward with this, targeting 3.6.3.
Assignee: nobody → coop
Status: NEW → ASSIGNED
If you go with 3.7.1+, `hg clone --uncompressed` / clone with "streaming clone bundles" is 3-4x faster on Windows. That improvement came as a result of RelEng's Windows people noticing how slow `hg clone` was on Windows. But I can't blame you for wanting to wait until 3.7.2, which should be released ~March 1 unless there is another unscheduled point release before. Also, Python wheels for 3.7 are now available at https://pypi.python.org/pypi/Mercurial/.
(Assignee)

Comment 5

3 years ago
Oh, I fully intend to *also* update to 3.7.2 once it's available, but I want us to get better/faster at the upgrade process.
(Assignee)

Updated

3 years ago
Duplicate of this bug: 854730
Let's use this bug to track the planned upgrade to 3.7.2 this week.
Summary: upgrade hg to >= 3.6 → upgrade hg to 3.7.2
https://s3-us-west-2.amazonaws.com/moz-packages/CentOS6/mercurial-3.7.2-1.x86_64.rpm (sha256: cc67d5809571e706268a675d6bae9d1dc6baa2f4fda0d94dd2b90b8f8421d510) can be installed on CentOS6 / RHEL6 machines. This is the same RPM we're currently using on hg.mozilla.org. Although it runs with the system Python (which is 2.6). On hg.mo, we install Mercurial into a virtualenv and run via Python 2.7.
(Assignee)

Updated

3 years ago
Depends on: 1260224
(Assignee)

Updated

3 years ago
Depends on: 1260226
Still early enough to switch to 3.7.3 for the sec fixes and issue 5103 ? https://www.mercurial-scm.org/wiki/WhatsNew for the changelog.
At this point 3.7.3 should be installed everywhere.
Summary: upgrade hg to 3.7.2 → upgrade hg to 3.7.3
(Assignee)

Updated

3 years ago
Depends on: 1259484, 1264089
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Depends on: 1270674
Blocks: 1298976
Component: Platform Support → Buildduty
Product: Release Engineering → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.