Closed Bug 122972 Opened 19 years ago Closed 17 years ago

To header gets split in four parts (commas in From/To fields)

Categories

(MailNews Core :: MIME, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: bugzilla, Assigned: bugzilla)

References

Details

Attachments

(1 file)

the following header:
To: =?iso-8859-1?Q?Medier_=26_Portal=2C_=D8st?=
	 <MediePortal.ost@xxx.xxx>

results in the folloing To line in Mozilla:
Medier, &, Portal, Øst <MediePortal.ost@xxx.xxx>
that's 4 recipients!

In outlook it's correctly detected as only one.

build 20020131
Attached file mail with header
Status: NEW → ASSIGNED
Summary: To header gets split in four parts → To header gets split in four parts
Target Milestone: --- → mozilla1.1alpha
*** Bug 174142 has been marked as a duplicate of this bug. ***
The same problem has From: field.
Commas must be MIMEd.
OS: Windows 2000 → All
Hardware: PC → All
Summary: To header gets split in four parts → To header gets split in four parts (commas in From/To fields)
Target Milestone: mozilla1.1alpha → ---
Can still confirm on Mozilla 1.5 final.

The problem appears only when the commas are encoded. The cases with unencoded
commas are separate bugs and seem to be fixed long ago.
Note that with current builds, the address is split only into two portions:
  Medier & Portal
  Øst <MediePortal.ost@xxx.xxx>

This is not because the comma was not MIMEd, but because it was not quoted.
Outlook's behavior is NOT correct -- an unquoted comma is an address delimiter, 
per RFC822.  The correct header would be:

To: =?iso-8859-1?Q?=22Medier_=26_Portal=2C_=D8st=22?=
 <MediePortal.ost@xxx.xxx>

Since the ampersand apparently used to be handled in error, this bug was not 
completely invalid, but it now works per spec.  =>WFM
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Well, I was mistaken.  The arguments for parsing per the desired behavior are 
well set out in the duplicate.

My apologies.

*** This bug has been marked as a duplicate of 254519 ***
Status: REOPENED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.