Closed Bug 174142 Opened 19 years ago Closed 18 years ago

Handling of commas in From:/To: fields

Categories

(MailNews Core :: Composition, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 122972

People

(Reporter: relf, Assigned: bugzilla)

Details

I've got a mail with the following 'From:' field

From: Un =?KOI8-R?Q?franc=2Cais?= de Bordeaux <xxxxx@yyyyy.fr>

When I clicked on Reply I got three 'To:' fields in the reply window:

To: Un
To: franc
To: de Bordeaux <xxxxx@yyyyy.fr>

I saved the message and saw in the draft filebox the only field

To:  Un,  franc, ais de Bordeaux <xxxxx@yyyyy.fr>

I'm not sure if commas should be escaped here, but at least displaying of this
field in the Reply window is incorrect.
Hardware: Other → All
I've just tried to send a reply and got an error. So commas in recipient name
must be escaped.

*** This bug has been marked as a duplicate of 122972 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.