Port Bug 1228444 (Rename DIST_FILES to FINAL_TARGET_PP_FILES) to DOM Inspector

VERIFIED FIXED

Status

Other Applications
DOM Inspector
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

Firefox Tracking Flags

(firefox45 affected)

Details

Attachments

(2 attachments)

Comment hidden (empty)
(Assignee)

Comment 1

2 years ago
Created attachment 8694776 [details] [diff] [review]
Rename DIST_FILES to FINAL_TARGET_PP_FILES

I left the |DIST_FILES = install.rdf | line in Makefile.in alone so that comm-aurora, etc can continue building.
Attachment #8694776 - Flags: review?(iann_bugzilla)

Comment 2

2 years ago
(In reply to Philip Chee from comment #1)
> Created attachment 8694776 [details] [diff] [review]
> Rename DIST_FILES to FINAL_TARGET_PP_FILES
> 
> I left the |DIST_FILES = install.rdf | line in Makefile.in alone so that
> comm-aurora, etc can continue building.

Shouldn't we tag/branch so that c-a then c-b then c-r, pick up the right fixes?
Flags: needinfo?(philip.chee)
(Assignee)

Comment 3

2 years ago
> Shouldn't we tag/branch so that c-a then c-b then c-r, pick up the right
> fixes?
I don't know. Did you try building comm-aurora with DOMi?
Flags: needinfo?(philip.chee)
(Assignee)

Comment 4

2 years ago
> Shouldn't we tag/branch so that c-a then c-b then c-r, pick up the right fixes?
*puts thinking cap on* On second thoughts you're right.

1. Create a new branch SEA_241_RELBRANCH.
2. Switch comm-aurora, comm-beta to pull Inspector from that branch.

What do you think?

Comment 5

2 years ago
(In reply to Philip Chee from comment #4)
> > Shouldn't we tag/branch so that c-a then c-b then c-r, pick up the right fixes?
> *puts thinking cap on* On second thoughts you're right.
> 
> 1. Create a new branch SEA_241_RELBRANCH.
> 2. Switch comm-aurora, comm-beta to pull Inspector from that branch.
> 
> What do you think?

If we're not planning on a new release of DOMI then, yes, but isn't c-b on 2.40 thus wouldn't it be SEA_240_RELBRANCH?

Comment 6

2 years ago
Comment on attachment 8694776 [details] [diff] [review]
Rename DIST_FILES to FINAL_TARGET_PP_FILES

r=me assuming relevant branch/tag is created.
Attachment #8694776 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1233969
(Assignee)

Comment 8

2 years ago
I checked this in to the DOMi repository
http://hg.mozilla.org/dom-inspector/rev/4dfc4e232cd5

This is after the uplift on 14 Dec so this change should work for mozilla-aurora/comm-aurora (SeaMonkey 2.42 Gecko 45) as well as mozilla-central.

The next step is to fix comm-beta and comm-release
(Assignee)

Comment 9

2 years ago
> The next step is to fix comm-beta and comm-release
comm-beta and comm-release client.py is set to DOMI_2_0_16 so that should work.
comm-central pulls from DOMi tip so that should be fine too.
Need to fix comm-aurora.
1. Create new tag DOMI_2_0_16_GECKO_45:
Added tag DOMI_2_0_16_GECKO_45 for changeset 4dfc4e232cd5
2. Tell the comm-aurora client.py to pull from it.
(Assignee)

Comment 10

2 years ago
Created attachment 8700320 [details] [diff] [review]
Tell comm-aurora (Gecko45) client.py to pull DOMi from tag DOMI_2_0_16_GECKO_45
Attachment #8700320 - Flags: review?(iann_bugzilla)
(In reply to Philip Chee from comment #8 dated 2015-12-19 08:40:42 PST)
> I checked this in to the DOMi repository
> http://hg.mozilla.org/dom-inspector/rev/4dfc4e232cd5

However, the latest 2.43a1 nightly so far is the one from 17 December i.e. before the fix. Due to (I've been told) this bug, it was built but with a faulty DOMi lacking a top-level install.rdf. As soon as the next linux-x86_64 nightly comes out I shall check that it comes with a properly installable and (AFAICT) usable DOMi.

Updated

2 years ago
Attachment #8700320 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 12

2 years ago
client.py patch checked-in to comm-aurora
https://hg.mozilla.org/releases/comm-aurora/rev/8123dae89ced
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
This build's DOMi now has an install.rdf (see dupe bug 1233969); its cZ still lacks one (parallel bug 1229810 isn't yet FIXED).

UA:"Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0 SeaMonkey/2.43a1" ID:20151220153800 c-c:076c24f6d01d0a5f0b14fb1cc80c17ff24dc9074 m-c:388bdc46ba51ee31da8b8abe977e0ca38d117434 en-US

Since this is a trunk build, the patch for it had already been pushed (see comment #8). I haven't found a 2.42a2 later than comment #12 but I'm confident that it will work.
Status: RESOLVED → VERIFIED
P.S. file:///usr/local/seamonkey/distribution/extensions/inspector@mozilla.org.xpi (this build's packaged-in DOMi) also installs successfully, which wasn't the case with the 2015-12-17 build.
You need to log in before you can comment on or make changes to this bug.