Status

defect
P2
minor
VERIFIED WONTFIX
22 years ago
4 months ago

People

(Reporter: dkindred=mozilla, Assigned: ramiro)

Tracking

1998-03-31
x86
Linux

Details

Attachments

(2 attachments)

Reporter

Description

22 years ago
Created by Darrell Kindred (dkindred=mozilla@cs.cmu.edu) on Wednesday, April 8, 1998 5:18:59 PM PDT
Additional Details :
Using Motif 1.2.4 under Linux, menus in HTML forms are not
wide enough for both the text of the longest item and the
little arrow button on the right.  It looks like the width
of the arrow is not taken into account.  For an example with
screenshot, see
  http://www.cs.cmu.edu/People/dkindred/bugs/menu-width.html
Updated by Ramiro Estrugo (ramiro@netscape.com) on Wednesday, April 29, 1998 2:46:32 AM PDT
Additional Details :
Assign to ramiro.

Yes the combo box sucks and has lots of bugs.  Thanks.

Comment 1

21 years ago
Hi Ramiro,

I believe I've tracked this bug down, and I might have a fix or at least an
analysis as soon as I can find some more time.

In fact, I was just wondering about the comment that you made on replacing
ComboBox at all. If you have something else to plug in already, we might just as
well "leave the ComboBox bugs be". Otherwise, we could fix ComboBox. I'll
volunteer to fix bugs on it, but obviously this wouldn't make sense if you throw
the whole thing out anyway. So, what's your opinion on that?

Comment 2

21 years ago
I know why ComboBox sometimes isn't wide enough, and why it's sometimes wider
than it should be, depending on the font being used.

The problem is that ComboBox tries to calculate the maximum length of the box by
going through all of the strings in the list and calculating the size based on
the current font.

HOWEVER: the font used to calculate the maximum length is wrong - it's always
the same one. The function where the font is calculated is called

static void
SetMaximumLabelSize(DtComboBoxPart *combo_p)

in DtWidgets/ComboBox.c

Later on, the font is assigned correctly. But is should have been assigned
already when the ComboBox size is calculated. I will plunge a bit deeper into
this.

Updated

21 years ago
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WONTFIX

Updated

21 years ago
Status: RESOLVED → VERIFIED

Comment 3

21 years ago
Old bug, old codebase. Marking won't fix. Re-open if I am incorrect.

Comment 4

19 years ago
check

Comment 5

18 years ago
Posted file ertertert

Comment 6

15 years ago
Posted image Screenshot

Updated

12 years ago
Duplicate of this bug: 383586

Comment 8

10 years ago
I am nnot fixing this bug
No longer blocks: 🍺

Updated

5 years ago
Duplicate of this bug: 1025612

Updated

3 years ago
Blocks: 1271962

Updated

4 months ago
Duplicate of this bug: 1526186
You need to log in before you can comment on or make changes to this bug.