Closed Bug 1230031 Opened 4 years ago Closed 4 years ago

Intermittent browser_perf-clear-02.js | This test exceeded the timeout threshold. It should be rewritten or split up.

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

Unspecified
Linux
defect
Not set

Tracking

(firefox45 affected)

RESOLVED FIXED
Tracking Status
firefox45 --- affected

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [test disabled])

Jordan, who could look into this?  It's currently on the list of top 30 intermittents.
Flags: needinfo?(jsantell)
Ah this is the test that just doesn't do anything for a minute until starting to run. Suspect it may be the previous test. Not sure. Leaving ni? here for now

 14:49:59     INFO -  190 INFO TEST-START | devtools/client/performance/test/browser_perf-clear-01.js
 14:50:28     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
 14:50:28     INFO -  MEMORY STAT | vsize 619MB | residentFast 176MB | heapAllocated 73MB
 14:50:28     INFO -  191 INFO TEST-OK | devtools/client/performance/test/browser_perf-clear-01.js | took 29614ms
 14:50:29     INFO -  192 INFO TEST-START | devtools/client/performance/test/browser_perf-clear-02.js
 14:51:26     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
 14:52:37     INFO -  TEST-INFO | started process screentopng
 14:52:39     INFO -  TEST-INFO | screentopng: exit 0
 14:52:39     INFO -  193 INFO checking window state
 14:52:39     INFO -  194 INFO Initializing a performance pane.
 14:52:39     INFO -  195 INFO Adding tab: http://example.com/browser/devtools/client/performance/test/doc_simple-test.html
 ... all tests run ...
 14:52:40     INFO -  256 INFO TEST-PASS | devtools/client/performance/test/browser_perf-clear-02.js | The record button should not be locked. -
 14:52:40     INFO -  257 INFO Destroying the performance tool.
 14:52:40     INFO -  258 INFO Removing tab.
 14:52:40     INFO -  259 INFO Tab removed and finished closing.
 14:52:40     INFO -  260 INFO finish() was called, cleaning up...
 14:52:40     INFO -  261 INFO TEST-UNEXPECTED-FAIL | devtools/client/performance/test/browser_perf-clear-02.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. -
 14:52:40
Possibly caused by bug 1169884 which landed shortly before these started occuring, although I've seen these before, and didn't think they were resolved.
Flags: needinfo?(jsantell)
Blocks: 384336
Bug 384336 makes this fail almost permanently. I'm going to disable this test on Linux.
OS: Unspecified → Linux
Whiteboard: [test disabled]
Might be fixed now that the patch in bug 1245886 has landed. Triaging this for now, filter on ORANGENGESCHMACK, if it reoccurs please reopen or file a new bug.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.