GaiaTest is using soon to be EOLed Treeherder API auth

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: emorley, Assigned: emorley)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.5 fixed, b2g-master fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
I've just noticed that Treeherder's API is access by gaiatest here:
https://github.com/mozilla-b2g/gaia/blob/23a94087e701c4bc592f2943e1007e25a9242f97/tests/python/gaia-ui-tests/gaiatest/mixins/treeherder.py

Is gaiatest still used?

I didn't see instances of it using oauth credentials in our logs as part of bug 1212936.

If it is still used, it needs updating asap before oauth support is removed. I'm happy to guide someone through that if it's not deadcode.

Few things that leap out:
1) It needs to be using treeherder-client 1.8.0 not 1.5 https://github.com/mozilla-b2g/gaia/blob/a9399f148859dc9dce73c4f2a2fd7653388aa9bc/tests/python/gaia-ui-tests/requirements.txt#L5
2) auth must be done via the TreeherderClient constructor, not on .post_collection() https://github.com/mozilla-b2g/gaia/blob/23a94087e701c4bc592f2943e1007e25a9242f97/tests/python/gaia-ui-tests/gaiatest/mixins/treeherder.py#L252-L253
3) oauth auth is deprecated, hawk auth should be used instead (see bug 1212936 comment 1)
4) The "Results are available at" URL is wrong here: https://github.com/mozilla-b2g/gaia/blob/23a94087e701c4bc592f2943e1007e25a9242f97/tests/python/gaia-ui-tests/gaiatest/mixins/treeherder.py#L255


Johan, can you help clarify the status of this file? (I see you changed it last)
Flags: needinfo?(jlorenzo)
Thanks for calling this out.

Gaitest is still used to run end-end automation on device. AFAIK, we've never sent any results to Treeherder, for the functional tests. It used to be a plan (like shown in bug 1043718), but we decided to move to Taskcluster (see bug 1225457). 

However, I know the perf team post results to Treeherder. They use version 1.8.0[1]. Rob, are you guys based on gaiatest? If not, I think it's okay to remove that next-to-be-bitrot piece of code. 

[1] https://github.com/rwood-moz/raptor-post/blob/master/requirements.txt#L3
Flags: needinfo?(jlorenzo) → needinfo?(rwood)

Comment 2

3 years ago
Hey, no Raptor doesn't use gaiatest (and we have our own treeherder hawk auth credentials etc). Thanks for checking though!
Flags: needinfo?(rwood)
Created attachment 8696337 [details] [review]
[gaia] edmorley:rm-gaiatest-treeherder-submission > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8696337 - Flags: review?(jlorenzo)
(Assignee)

Updated

3 years ago
Assignee: nobody → emorley
Status: NEW → ASSIGNED
Duplicate of this bug: 1230966
Comment on attachment 8696337 [details] [review]
[gaia] edmorley:rm-gaiatest-treeherder-submission > mozilla-b2g:master

Thank you for handling the removal. I tried the changes locally, I was still able to run gaiatest.

I also looked up for usages of the classes deleted, I couldn't find any leftover. |git grep -i treeherder| in the gaia-ui-tests folder didn't return anything.

All looks good to me!
Attachment #8696337 - Flags: review?(jlorenzo) → review+
As bug 1230966 showed, out Jenkins jobs started to fail due to treeherder-client 1.5.0 not being on Pypi anymore. In order to get them back working, I merged the PR in master at: https://github.com/mozilla-b2g/gaia/commit/961528f4391668bc89ec0be14fa367cea099b588
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

3 years ago
Many thanks for merging to fix that - sorry for the confusion :-)
Blocks: 1228554
Created attachment 8699457 [details] [review]
[gaia] JohanLorenzo:bug-1230244-v2.5 > mozilla-b2g:v2.5
As treeherder v1.5.0 is not available anymore, we also need to remove it from 2.5. I uplifted the patch, tested locally and landed in 2.5 at:

https://github.com/mozilla-b2g/gaia/commit/679b3736806b0878b3cc5809dd37dbc9095d4d23
status-b2g-v2.5: --- → fixed
status-b2g-master: --- → fixed
You need to log in before you can comment on or make changes to this bug.