Closed Bug 1230582 Opened 4 years ago Closed 4 years ago

Action Bar is not invoked when tapping an empty search text area

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 46
Tracking Status
firefox42 --- unaffected
firefox43 --- unaffected
firefox44 --- unaffected
firefox45 --- affected
firefox46 --- verified
fennec 46+ ---

People

(Reporter: TeoVermesan, Assigned: TYLin)

References

Details

(Keywords: regression)

Attachments

(2 files)

Steps to reproduce:
1. Go to imdb.com
2. Tap the search text box to invoke action bar

Expected results:
- Action bar is displayed

Actual results:
- Nothing happens

Note:
- when some letters are typed in the search box, the action bar is invoked
Teodora, what are you calling the action bar here? Perhaps you have a screenshot? I wouldn't expect it to appear when tapping the search text box.
Flags: needinfo?(teodora.vermesan)
The action bar contains the "Paste" and "Add as a search engine" options.
I have 23-11 nightly build and works ok.
On latest Nightly, the action bar does not appear on tap/long tap/ double tap.
Flags: needinfo?(teodora.vermesan)
Keywords: regression
Blocks: GeckoCaret2
tracking-fennec: --- → ?
Flags: needinfo?(markcapella)
fyi, this is designed to follow FF/OS (the new AccessibleCarets spec/implementation) ... see [0], around page 10, "Empty Input"

[0] https://bugzilla.mozilla.org/attachment.cgi?id=8548759
Flags: needinfo?(markcapella)
Duplicate of this bug: 1231182
On B2G, when long-pressing on an empty input, the copy/paste/cut menu will be shown. The float bubble listens to CaretStateChanged event with reason CaretChangedReason::Longpressonemptycontent in [1]. However, the spec in page 9 indicates that only show the cursor without a blue caret.

Does ActionBar show only when the carets are visually visible? Or does the ActionBar show when carets are logically visible as well? If Fennec UX requires that the blue caret shows when the input is empty like the old Fennec did, I could help add a preference to control that.

[1] https://dxr.mozilla.org/mozilla-central/rev/2bdd9ec79799eff3ceec0a318f5a0632d918a527/layout/base/AccessibleCaretManager.cpp#469
Flags: needinfo?(markcapella)
tylin, yes the current actionbar state follows actual caret visibility, opening [0] ... Looks like you'd tweak a pref here? [1] 

[0] http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/ActionBarHandler.js?rev=2d4cfc1c9e97&mark=36-36#28
[1] http://mxr.mozilla.org/mozilla-central/source/layout/base/AccessibleCaret.cpp?rev=169d9adca23f&mark=256-256#241
Flags: needinfo?(markcapella)
I'll add sCaretsExtendedVisibility in [1] and probably with some tests so that the blue caret is shown on an empty input on Fennec.

[1] https://dxr.mozilla.org/mozilla-central/rev/319be5e7ce3061c7c16f24d750b6dacdbcac4c35/layout/base/AccessibleCaretManager.cpp#262
Assignee: nobody → tlin
tracking-fennec: ? → 46+
Comment on attachment 8700507 [details] [diff] [review]
Always show caret even if input is empty on Fennec. f=capella, r=roc

Mark, would you help test whether this patch works on Fennec?
Attachment #8700507 - Flags: feedback?(markcapella)
Comment on attachment 8700507 [details] [diff] [review]
Always show caret even if input is empty on Fennec. f=capella, r=roc

Review of attachment 8700507 [details] [diff] [review]:
-----------------------------------------------------------------

Nice ! This works for me :-)
Attachment #8700507 - Flags: feedback?(markcapella) → feedback+
Attachment #8700507 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/df0941b629c3
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
Verified as fixed on the latest Nightly build (46.0a1 / 2015-12-27) on Nexus tab 7 with Android 5.1.1, Samsung Galaxy Tab S2 with Android 5.0.2 and on Samsung Galaxy S6 Edge, also with Android 5.1.1
You need to log in before you can comment on or make changes to this bug.