Closed Bug 12307 Opened 21 years ago Closed 20 years ago

this.form.(radio button)[1].value not works

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 18840

People

(Reporter: boyarsh, Assigned: pollmann)

References

Details

Attachments

(7 files)

Mozilla M8
In this code:
"<tr><td><input type="radio"
name="Row" value="246"
onclick="parent.window.frames[2].location='Smeta.Foot.php3?Row='+this.form.Row[1].value+
'&bp=00173'"><td>1999 год
<tr><td><input type="radio"  name="Row" value="281"
onclick="parent.window.frames[2].location='Smeta.Foot.php3?Row='+this.form.Row[2].value+'&bp=00173'"><td>1999
год"
when clicking on radio button I get message "this.form.Row[2].value has no
propertis" and location don't changes. Also "Row[2].value has no propertis"
In NS4.6 that's Ok
gerardok, can you reproduce this?  Is this Linux only?
Attached file testcase
Attached file frame1
Attached file testframe
Attached file frame3
Attached file frame3b
OS: Linux → All
Hardware: PC → All
Steps to reproduce:

1. Download the attached files:

 - testcase
 - testframe
 - frame1
 - frame3
 - frame3b

where the content for the testframe is:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML>
<HEAD>
<TITLE>test.html</TITLE>
</HEAD>
<BODY>
<FORM action="donothing.cgi" method="post">
<TABLE>
<TBODY>
<tr><td><input type="radio" name="Row" value="1"
onclick="parent.window.frames[2].location='hello'+this.form.Row[0].value+'.html'
"><td>Display Hello 1
<tr><td><input type="radio"  name="Row" value="2"
onclick="parent.window.frames[2].location='hello'+this.form.Row[1].value+'.html'
"><td>Display Hello 2
</TBODY>
</TABLE>
</FORM>
</BODY>
</HTML>

2. Load the testcase file in apprunner
3. Click on the first RadioButton

Actual Results: The JavaScript error "this.form.Row[0] has no properties" is
displayed in the console.

Expected Results: frame3 file ("Hello 1") displayed in the third frame to the
right.

Build ID & Platforms Tested On:

1999-08-30-10-M10 on Win NT
1999-08-30-02-M10 on Linux
1999-08-30-10-M10 on Mac

Updated OS and Platform information.
*** Bug 18174 has been marked as a duplicate of this bug. ***
Assignee: vidur → pollmann
*** Bug 15361 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Target Milestone: M12
Target Milestone: M12 → M13
*** Bug 19460 has been marked as a duplicate of this bug. ***
I can reproduce the error in build M11 under Windows 98 with this simple test
case (enclosed also):

<FORM>
<INPUT TYPE=RADIO NAME="set">
<INPUT TYPE=RADIO NAME="set">
</FORM>

<SCRIPT>
document.writeln('Number of radio buttons = ' + document.forms[0].set.length
+ ' (should be 2)');
</SCRIPT>
*** Bug 19576 has been marked as a duplicate of this bug. ***
Attached file checkbox array example
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 18840 ***
Status: RESOLVED → VERIFIED
Verified dupe of bug 18840
Identically named radio and checkbox inputs don't create expected arrays.
*** Bug 85113 has been marked as a duplicate of this bug. ***
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.