If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Printing of images and links with postscript is very broken

VERIFIED INVALID

Status

()

Core
Printing: Output
--
critical
VERIFIED INVALID
17 years ago
16 years ago

People

(Reporter: Oliver Jones, Assigned: dcone (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
View the attached postscript file in ggv (GNOME GhostView) for a demonstration 
of how positively broken moz's print engine is.  This postscript file is 
rejected by ghostscript when trying to print on my BJC620.  Other simpler pages 
work (ie, plain text emails etc).

Browser: Moz/5 0.9.1 on RedHat Linux 7.1
(Reporter)

Comment 1

17 years ago
Created attachment 37869 [details]
Postscript of printed page.  Very fux0red output.

Comment 2

17 years ago
Assign to Roland.
Assignee: katakai → Roland.Mainz
QA Contact: Roland.Mainz → katakai

Comment 3

17 years ago
Oliver:
The PostScript code starts with
-- snip --
%!PS-Adobe-3.0
%%BoundingBox: 36 36 559 769
%%Creator: Mozilla (NetScape) HTML->PS
%%DocumentData: Clean8Bit
%%DocumentPaperSizes: A4
%%Orientation: Portrait
%%Pages: (atend)
%%PageOrder: Ascend
%%Title: AutoSupply New Zealand (LMVD): Japanese and European Used Cars for
Sale. Japanese Import, Toyota, Mazda, Nissan, Honda, Isu
zu, Mitsubishi, Suzuki, Mercedes, BMW
%%EndComments
% MozillaCharsetName: iso-8859-1
-- snip --

This output is definately not from Xprt (the print engine used by Xprint
module).

Setting component to "Printing" to track issues caused by the native PostScript
module... Oliver: "Xprint-module" is an alternative to Mozilla's native
PostScript module...
Component: Printing: Xprint → Printing

Comment 4

17 years ago
Reassigning to owner of native PostScript module...
Assignee: Roland.Mainz → dcone
QA Contact: katakai → sujay

Comment 5

16 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Printing of images and links is very broken. → Printing of images and links with postscript is very broken
(Assignee)

Comment 6

16 years ago
If your talking about the black backgrounds.. those are transparent gifs..and 
transparent images are broken.. not supported yet.. on printing.  This is a 
duplicate of 12307.

*** This bug has been marked as a duplicate of 12307 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
v
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

16 years ago
I am NOT JUST talking about the images.  Yes the images are stuff yes I know
that and ok so the bug is a dup in that respect.  However everything else is
also fux0red.

You will note that if viewed in ggv 1.0 (Gnome Ghost View) that the GIF's are
scaled to many times larger than they should be and links have excessive
spacinging around them.  eg, text that should read "this link here" reads
"this         link     here"  where 'link' is a link.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 9

16 years ago
This is not a description of a bug.  Can describe what is wrong.. and assign a 
bug to each thing that is wrong.   The point of my comment.. is you must 
describe a bug.. then I can fix that problem.. not an array of problems or an 
image that does not look correct.  Can you change this bug into a description of 
a problem.  And even better.. come up with an example that shows the problem 
exactly.  Also.. try printing out the example.. does that look ok?  It is hard 
for me to guess or let say I fixed the transparency.. you could keep coming back 
saying something else did not look right.  Like you said.. your not just talking 
about images.. keep one bug to one issue.

Comment 10

16 years ago
Reporter, please refile a bug with a specific statement. The bug for transparent
images is currently filed and in progress, and this bug has been duped before.
When reporting a bug, it's makes our life a lot easier if you produce a clear
statement and steps to reproduce, unless it's so obvious we won't miss it. 

Thanks! 
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID

Comment 11

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.