Text blinks (appears/disappears) on Codepen/Youtube when I resize window/change zoom level after hard-refresh

RESOLVED DUPLICATE of bug 1188802

Status

()

Core
Graphics: Text
P3
normal
RESOLVED DUPLICATE of bug 1188802
2 years ago
a year ago

People

(Reporter: arni2033, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox45- affected)

Details

(Whiteboard: [gfx-noted][fixed by bug 1188802], URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8696356 [details]
screencast 1 - Text flickers on codepen.io.webm

>>>   My Info:   Win7_64, Nightly 45, 32bit, ID 20151206030448
STR:
1. Open http://codepen.io/pen/ , wait until the page is fully loaded
2. Click urlbar, press Ctrl+Shift+R to reload the page w/o using cache, wait until it's fully loaded
3. Switch window to normal (not maximized) mode
4. Try to slowly resize the window vertically (to change its height)

Result:       
 All white text in toolbars (on the page) disappears/reappears

Expectations: 
 Text should stay still w/o flickering, just like in GoogleChrome.

This was regressed between 2014-04-17 and 2014-04-18. Pushlog_url:
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e71ed4135461&tochange=7fe3ee0cf8be
Looks like it was caused by changes made in bug 964613.
John, I believe you're the right person to ask whether 964613 is the right bug.
Flags: needinfo?(jdaggett)
(Reporter)

Comment 1

2 years ago
The same happens with another url: https://www.youtube.com/ when I resize window in normal mode from the maximum height to minimal height and back. This behavior has the same regression range.
Whiteboard: [gfx-noted]
(Reporter)

Updated

2 years ago
Has STR: --- → yes

Comment 2

2 years ago
Bizarre. I can reproduce this under Windows 8.1 and OSX.
Assignee: nobody → jdaggett
Flags: needinfo?(jdaggett)

Updated

2 years ago
Priority: -- → P3
(Reporter)

Comment 3

2 years ago
I recommend to simply change zoom level instead of window resizing in Steps 3,4 - it still shows
the same bug even on those sites where original STR did nothing. E.g. this site:
> https://www.google.com/fonts/specimen/Codystar
Summary: Text flickers (appears/disappears) on http://codepen.io/pen/ when I resize window after hard-refresh → Text blinks (appears/disappears) on Codepen/Youtube when I resize window/change zoom level after hard-refresh

Updated

2 years ago
Assignee: jd.bugzilla → nobody
tracking-firefox45: --- → -
Jonathan, something that you can deal with?
Assignee: nobody → jfkthame
(Reporter)

Updated

2 years ago
Assignee: jfkthame → nobody
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Whiteboard: [gfx-noted] → [gfx-noted][fixed by bug 1188802]
Duplicate of bug: 1188802
(Reporter)

Updated

a year ago
See Also: → bug 1328059
You need to log in before you can comment on or make changes to this bug.