Text on the page blinks after hard-refresh when I edit irrelevant CSS rules in devtools

REOPENED
Unassigned

Status

()

Core
CSS Parsing and Computation
P3
minor
REOPENED
a year ago
7 months ago

People

(Reporter: arni2033, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (obsolete)
(Reporter)

Updated

a year ago
No longer blocks: 1277113
(Reporter)

Updated

a year ago
Component: Untriaged → Layout: Text
Product: Firefox → Core
Unfortunately, the site appears to be gone now.
Loading the URL shows the text "File not found" with no other content.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INCOMPLETE
Comment hidden (obsolete)

Comment 3

a year ago
The issue appears to be reproducible on any site with downloadable fonts. Could you check STR_2?
(please hide comment 2, it's incorrect.

>>>   My Info:   Win7_64, Nightly 53, 32bit, ID 20170107030205 (2017-01-07)
STR_2:
1. Open bug 1268736 , reload it using Ctrl+Shift+R
2. Inspect element "#bugzilla-body", find rule "margin: 10px auto 15px;" in ruleview, click on "10px"
3. Press Up key, wait 5 seconds
4. Press Down key, wait 5 seconds

AR:  After Step 3 and Step 4 text on the page blinks. Font file is requested multiple times.
     New requests appear in Netmonitor/console, and each of them says "cached"
ER:  Text shouldn't blink
I can reproduce the STR in comment 2 in Nightly 53.0a1 (2017-01-07) (64-bit) on Linux.

The Network tab adds new requests for some FireSans woff fonts in step 3/4.
They are listed as "Transferred: Cached".
There is also a noticeable flash on the page that happens - it's more noticeable
when the page is scrolled down a bit to begin with.
Severity: normal → minor
Status: RESOLVED → REOPENED
Component: Layout: Text → CSS Parsing and Computation
Flags: needinfo?(mats)
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: INCOMPLETE → ---
The claimed regression range (in comment 0) is:
> This is regression from bug 964613 (between 2014-04-17 and 2014-04-18). Regression range:
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e71ed4135461&tochange=7fe3ee0cf8be
I haven't confirmed it, but it seems plausible.
It does seem odd that we'd trigger font requests when editing a CSS rule
that contains no font properties.  So that's why I figured the root cause
might be in the style system.  It might also be something that the devtools
code does.
> I can reproduce the STR in comment 2 in Nightly 53.0a1 (2017-01-07) (64-bit) on Linux.

Bah, I meant comment 3 of course.

Updated

7 months ago
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.