At editing ISO-2022-JP email which has long lines with "Forward", the long line is separated to multiple lines and quoted but each line is wrapped by editor again

RESOLVED DUPLICATE of bug 1230968

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 1230968
2 years ago
2 years ago

People

(Reporter: masayuki, Unassigned)

Tracking

({jp-critical})

Firefox Tracking Flags

(Not tracked)

Details

STR:

1. Save the attachment as a .eml file
2. Import it to Daily.
3. Select the email.
4. Right click and choose "Forward"

Expected Result:

The quoted message is wrapped by the editor or forcibly wrapped at quoted and each line won't be wrapped.

Actual Result:

Separated lines are wrapped by the editor (perhaps, with max column settings?)

I guess that this is not a regression actually if such email came from other MUAs. However, this is *new*, this becomes reproducible *only* with Thunderbird.

Comment 1

2 years ago
There is no attached e-mail. Do you mean the one from bug 1230968, attachment 8696494 [details]?
Flags: needinfo?(masayuki)
Summary: At editing ISO-2022-JP email which has lone lines with "Forward", the lone line is separated to multiple lines and quoted but each line is wrapped by editor again → At editing ISO-2022-JP email which has long lines with "Forward", the long line is separated to multiple lines and quoted but each line is wrapped by editor again
(In reply to Jorg K (GMT+1) from comment #1)
> There is no attached e-mail. Do you mean the one from bug 1230968,
> attachment 8696494 [details]?

Oh, yes. I cloned the bug and forgot to change the explanation, sorry for the mistake.
Flags: needinfo?(masayuki)

Comment 3

2 years ago
Actually, I don't understand the description. I have the suspicion that this has something to do with bug 1230968 since both "edit as new" and forward were affected by the problem.

Bug 1230968 already landed, so can you please retest this with a daily as of 9th Dec. and let me know.

Please note that due to bug 1231017 the flowing is lost and the message is wrapped at forward. If that's what you're complaining about, this is a duplicate of bug 1231017, which already existed in TB 38. Try attachment 8696538 [details] to see that it has nothing to do with Japanese or ISO-2022-JP.

If possible/necessary please include as screenshot of the problem.
Keywords: regression

Comment 4

2 years ago
I'm reading the summary again:

At editing ISO-2022-JP email which has long lines with "Forward", the long line is separated to multiple lines ... (yes, flowing is lost, bug 1231017) ...
and quoted ... (no, forwarding doesn't quote) ... but each line is wrapped by editor again (that I don't understand at all).
Flags: needinfo?(masayuki)
> Bug 1230968 already landed, so can you please retest this with a daily as of 9th Dec. and let me know.

Yeah, if it's still bad, I'll attach screenshot.

Comment 6

2 years ago
Looking at this problem again with a version that includes the fix from bug 1230968.

I shift forward the message and receive a plain text composition window, remember, this has style "white-space:pre-wrap; width:72", so the message appears wrapped, see bug 1230974 which complains about that.

When sending the message, this is the received content after adding "HUHU" at the top.

===================
Content-Type: text/plain; charset=iso-2022-jp; format=flowed; delsp=yes
Content-Transfer-Encoding: 7bit

HUHU


-------- Forwarded Message --------
Subject: $B%F%9%H(B
Date: Tue, 8 Dec 2015 01:24:35 +0900
From: foo@example.com
To: foo@example.com

$B%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H(B 
$B%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H%F%9%H(B 
===================

Note that there are spaces at the end of the lines of the forwarded part, unlike bug 1231017 where the spaces are removed from the forwarded part.

So the result is a perfectly flowed message.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(masayuki)
Resolution: --- → DUPLICATE
Duplicate of bug: 1230968

Comment 7

2 years ago
I updated to the daily of today, 45.0a1 (2015-12-09).

Plain text forward of the message in attachment 8696494 [details] works well now, of course the message is wrapped in the composition window (bug 1230974).
You need to log in before you can comment on or make changes to this bug.