Tab Groups migration page is not focused after the migration

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: simona.marcu, Unassigned)

Tracking

45 Branch

Details

Mozilla/5.0 (X11; Linux i686; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151208030212

After updating to Firefox 45, the "Tab Groups are no more. Sorry" page is opened, but it's not in focus. The user might easily miss it.

Steps to reproduce:
1. Install Firefox 44 (the latest Nightly 44.0a1)
http://archive.mozilla.org/pub/firefox/nightly/2015/10/2015-10-29-03-02-58-mozilla-central/
2. Create at least 2 panorama tab groups, each with at least 3 tabs opened
3. Update to Firefox 45 (the latest Nightly 45.0a1)

Expected results: 
As a panorama user I was informed that Tab groups will be migrated (Bug 1221500). The "Tab Groups migration page" is focused allowing me to open windows and tabs or to open the bookmarks window.

Actual results:
The "Tab Groups migration page" is opened, but the First run page is in focus. Considering that I already have 3 other tabs opened  from step 2 plus the First run page, it's very easy to ignore it.

Comment 1

3 years ago
Are we going to use a First run page for the 45 release, and if so, what's the desired behaviour here? It could be quite difficult to get this page to "override" the first run page.
Flags: needinfo?(mverdi)

Comment 2

3 years ago
(In reply to :Gijs Kruitbosch from comment #1)
> Are we going to use a First run page for the 45 release, and if so, what's
> the desired behaviour here? It could be quite difficult to get this page to
> "override" the first run page.

The migration page should only ever be shown to people who upgrade and people who upgrade should never see a first run page. First run pages are only supposed to be shown to new installations. Now a user who upgrades can be shown a "what's new" page but I don't know of a plan to show a what's new page to Firefox 45 users (but that doesn't mean there isn't one). 

Following the steps in comment 0 I see the Nightly first run page with the new installation and then for some reason I see it again after upgrading. I don't know why that would show up a second time (unless it shows up with each major version?). Let's say seeing the nightly first run page a second time is not a bug, shouldn't nearly everyone on nightly now be on 46 and have already gone though the migration? 

I'll look into plans for what's new pages on other channels. The one problem that I can see now is if the user has 44 and Windows 7 or 8 and then upgrades to Windows 10 and Firefox 45 at the same time. In that case we also show the special "Welcome" page - https://www.mozilla.org/en-US/firefox/windows-10/welcome/ . I don't believe it's designed to be focused though.
Flags: needinfo?(mverdi)

Comment 3

3 years ago
(In reply to Verdi [:verdi] from comment #2)
> (In reply to :Gijs Kruitbosch from comment #1)
> Following the steps in comment 0 I see the Nightly first run page with the
> new installation and then for some reason I see it again after upgrading. I
> don't know why that would show up a second time (unless it shows up with
> each major version?). Let's say seeing the nightly first run page a second
> time is not a bug, shouldn't nearly everyone on nightly now be on 46 and
> have already gone though the migration? 

Right, the problem is whether the same thing will happen on the release channel and take focus away from the tab groups migration page.

> I'll look into plans for what's new pages on other channels. The one problem
> that I can see now is if the user has 44 and Windows 7 or 8 and then
> upgrades to Windows 10 and Firefox 45 at the same time. In that case we also
> show the special "Welcome" page -
> https://www.mozilla.org/en-US/firefox/windows-10/welcome/ . I don't believe
> it's designed to be focused though.

Seems like this was implemented in bug 1185012. From looking at the code, I don't know what the behaviour would be in that case. Jared, do you know? But it also seems like a very small edgecase to be updating both at exactly the same time...

Comment 4

3 years ago
(In reply to :Gijs Kruitbosch from comment #3) 
> Right, the problem is whether the same thing will happen on the release
> channel and take focus away from the tab groups migration page.

There is no what's new page planned for Firefox 45 on release.

Comment 5

3 years ago
(In reply to Verdi [:verdi] from comment #4)
> (In reply to :Gijs Kruitbosch from comment #3) 
> > Right, the problem is whether the same thing will happen on the release
> > channel and take focus away from the tab groups migration page.
> 
> There is no what's new page planned for Firefox 45 on release.

OK. Based on this and the fact that 45 is off nightly already, and that fixing this is likely non-trivial anyway because we'd need to modify behaviour for the *other* pages that would otherwise mess with this one, I'd like to suggest WONTFIX. Verdi/Dolske, does that sound OK to you?
Flags: needinfo?(mverdi)
Flags: needinfo?(dolske)

Comment 6

3 years ago
Sounds ok to me.
Flags: needinfo?(mverdi)
WFM.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(dolske)
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.