Closed Bug 1231153 Opened 5 years ago Closed 5 years ago

[BACKEND] Create API to allow Tools to pass custom context menus to table and tree widgets

Categories

(DevTools :: Storage Inspector, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1231437

People

(Reporter: miker, Assigned: miker)

References

Details

Our approach should be the same for both the tree and the table widgets and should be completely generic.

We should allow each of the widgets to accept an object such as the following:

    [
      {
        item: "Remove cookie"
        message: "storage:storage-cookie-request-parent",
        methodName: "clearCookie"
      },
      {
        item: "Remove all cookies"
        message: "storage:storage-cookie-request-parent",
        methodName: "clearAllCookies"
      },
    ]

For the storage inspector this will most probably passed in via ui.js::fetchStorageObjects()
We also need hotkey: VK_BLAH
Summary: Create API to allow Tools to pass custom context menus to table and tree widgets → [BACKEND] Create API to allow Tools to pass custom context menus to table and tree widgets
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1231437
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.