[meta] Edit/Delete/Add support for Storage Inspector

RESOLVED FIXED

Status

enhancement
P2
normal
RESOLVED FIXED
5 years ago
6 months ago

People

(Reporter: Optimizer, Assigned: miker)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 obsolete attachments)

Comment hidden (obsolete)
(Reporter)

Updated

5 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
Comment hidden (obsolete)
(Reporter)

Updated

5 years ago
Assignee: nobody → scrapmachines
Status: NEW → ASSIGNED
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
Duplicate of this bug: 1062608
(Reporter)

Updated

5 years ago
Duplicate of this bug: 1064250
Duplicate of this bug: 1097796

Comment 10

4 years ago
Firebug.next report:
https://github.com/firebug/firebug.next/issues/373

Any news for this enhancement? It was really appreciated in Firebug 2.0 and it would be great to have it in Firebug 3.0.

Florent
Comment hidden (obsolete)
Flags: needinfo?(scrapmachines)
Note that the using JSON to serialize indexedDB values is by definition lossy (as experienced in bug 1159545) since IndexedDB values have the full fidelity of the structured clone algorithm, so it might be advisable to remove IndexedDB support from this patch until:
- Structured clone is used for transit for IndexedDB values (bug 1159545 or whatever it gets duped to or ends up depending on)
- Blobs are dealt with (bug 1054028 touches on this).  This probably needs to be handled by creating a devtools managed handle system that holds onto the Blob reference from the object and gives it some unique identifier.  Then when the object is re-constituted in the actual process, the Blob reference can be reconstituted.
See Also: → 1159545
Comment hidden (obsolete)

Updated

4 years ago
Assignee: scrapmachines → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(scrapmachines)
Duplicate of this bug: 1138075
Duplicate of this bug: 1136739
Assignee: nobody → mratcliffe
Alias: rw-storage

Updated

4 years ago
Depends on: 1194190

Updated

4 years ago
Blocks: 1194190
No longer depends on: 1194190

Updated

4 years ago
Duplicate of this bug: 1170440

Comment 17

4 years ago
Split off the patch in smaller parts. This is all :Optimizer's work, which is why I kept his name.
Attachment #8600591 - Attachment is obsolete: true
Comment hidden (obsolete)

Comment 19

4 years ago
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #18)
> @ntim: Can you let us know the status of this bug... I mean, does the patch
> work?
I haven't finished splitting up the patch, and the only one I have is the one I've uploaded here, which I haven't tested (requires the rest of the patch).

The very old "Rebased Patch" is obsolete with the e10s work that has been done.
Flags: needinfo?(ntim.bugs)
Comment hidden (obsolete)
Comment hidden (obsolete)
Flags: needinfo?(ntim.bugs)
Depends on: 1205092
Depends on: 1205097
Depends on: 1205104
Depends on: 1205106

Updated

4 years ago
Depends on: 1205113
Depends on: 1205114
Depends on: 1205116
Depends on: 1205119
Depends on: 1205120
Depends on: 1205122
Depends on: 1205123

Comment 22

4 years ago
(In reply to Sebastian Zartner [:sebo] from comment #20)
> Tim, Mike, would it make sense splitting this bug into smaller ones, so each
> storage feature can be tackled individually?
> 
> Sebastian

I'm not too fond of doing this, because we may end up shipping code with comments like "unimplemented", whereas here, we could have had written multiple patches then ship them when everything is done.

But since you've already filed bugs, that should be fine too. I've changed your bugs to backend bugs, simply because it's more convenient to add an UI when everything is done instead of handling uimplemented functionality in the UI. Also, I've merged edit/add with delete bugs since they share the same underlying work. IndexedDB is a different story so the separation should be fine.
Comment hidden (obsolete)
No longer depends on: 1205120
No longer depends on: 1205114
No longer depends on: 1205122
Summary: Edit/Delete/Add support for Storage Inspector → [meta] Edit/Delete/Add support for Storage Inspector
(In reply to Tim Nguyen [:ntim] from comment #22)
> (In reply to Sebastian Zartner [:sebo] from comment #20)
> > Tim, Mike, would it make sense splitting this bug into smaller ones, so each
> > storage feature can be tackled individually?
> > 
> > Sebastian
> 
> I'm not too fond of doing this, because we may end up shipping code with
> comments like "unimplemented", whereas here, we could have had written
> multiple patches then ship them when everything is done.
> 
> But since you've already filed bugs, that should be fine too. I've changed
> your bugs to backend bugs, simply because it's more convenient to add an UI
> when everything is done instead of handling uimplemented functionality in
> the UI. Also, I've merged edit/add with delete bugs since they share the
> same underlying work. IndexedDB is a different story so the separation
> should be fine.

@ntim: Forget about us splitting this up... can you tell me the status of this bug e.g. what works and doesn't work. We are planning on landing this very soon so we need to get things moving and I am happy to base my changes on top of your code.
Flags: needinfo?(ntim.bugs)

Comment 25

3 years ago
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #24)
> @ntim: Forget about us splitting this up... can you tell me the status of
> this bug e.g. what works and doesn't work. We are planning on landing this
> very soon so we need to get things moving and I am happy to base my changes
> on top of your code.

The only patch I had finished rebasing was the TableWidget patch (which I've posted). I had some incomplete rebases of the rest of the patch, but never got the time to finish them, and now they're all outdated with the file move.
Flags: needinfo?(ntim.bugs)
No longer depends on: 1205119
No longer depends on: 1205123
No longer depends on: 1205116
Duplicate of this bug: 1231901

Updated

3 years ago
Duplicate of this bug: 1149342

Updated

3 years ago
Duplicate of this bug: 1243316

Updated

3 years ago
Blocks: 1194190

Updated

3 years ago
Depends on: 1259946

Updated

3 years ago
No longer depends on: 1259946

Updated

3 years ago
Depends on: 1268844

Updated

3 years ago
No longer depends on: 1268844
Depends on: 1268844
No longer depends on: 1268844

Comment 29

3 years ago
Will the ability to add data in Storage inspector be implemented?

Updated

3 years ago
Depends on: 1279602
Depends on: 1311322
Depends on: 1336934
No longer blocks: 1194190
Priority: -- → P2
No longer depends on: 1251563, 1311322
Attachment #8648517 - Attachment is obsolete: true
All relevant dependencies are fixed, closing.
Alias: rw-storage
Severity: normal → enhancement
Status: NEW → RESOLVED
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Last Resolved: a year ago
Resolution: --- → FIXED
Whiteboard: [storage]

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.