Carats appears on FTU's subheader after user taps select all bubble.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::First Time Experience
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: Verson Xiong (Leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-master affected)

Details

(Whiteboard: [2.5-aries-test-run-4])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8696921 [details]
AriesKK_v2.5.3gp

[1.Description]:
[Aries KK v2.5&master][Flame v2.5&master]:On FTU's join hidden network page, if user tries to select all strings via utility bubble, redundant carats appears on subheader.
Attach: Arieskk_v2.5.3gp

[2.Testing Steps]: 
Precondition: launch FTU via flash device.

1. Navigate to select wifi page.
2. Tap "Join hidden network" button.
3. Input any words to SSID/Password textfield.
4. Long tap string to invoke utility bubble.
5. Tap select all.

[3.Expected Result]: 
5. All strings in textfield will be selected, and no redundant carats appears.

[4.Actual Result]: 
5. Redundant carats appears on subheader.

[5.Reproduction build]: 
Device: Flame KK master_512mb(affected)
Build ID               20151208150206
Gaia Revision          6b430ea7274af4c352de16b75e6bb85d7621ca83
Gaia Date              2015-12-08 06:31:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a8965ae93c5d098a4f91ad9da72150bb43df07a7
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151208.183034
Firmware Date          Tue Dec  8 18:30:47 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK master(affected)
Build ID               20151208222037
Gaia Revision          6b430ea7274af4c352de16b75e6bb85d7621ca83
Gaia Date              2015-12-08 06:31:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a8965ae93c5d098a4f91ad9da72150bb43df07a7
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151208.213715
Firmware Date          Tue Dec  8 21:37:23 UTC 2015
Bootloader             s1

Device: Flame KK 2.5_512mb(affected)
Build ID               20151208120554
Gaia Revision          2d54c29f429bed790b5d8284633812dc2b782518
Gaia Date              2015-12-02 14:41:15
Gecko Revision         http://hg.mozilla.org/releases/mozilla-

b2g44_v2_5/rev/ff31a251b2f6149edf4fc0a199133ef2e190ceac
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151208.111719
Firmware Date          Tue Dec  8 11:17:29 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(affected)
Build ID               20151208121136
Gaia Revision          2d54c29f429bed790b5d8284633812dc2b782518
Gaia Date              2015-12-02 14:41:15
Gecko Revision         http://hg.mozilla.org/releases/mozilla-

b2g44_v2_5/rev/ff31a251b2f6149edf4fc0a199133ef2e190ceac
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151208.111803
Firmware Date          Tue Dec  8 11:18:12 UTC 2015
Bootloader             s1


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
FreeTest
(Reporter)

Updated

2 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
If memory serves, the bug here is that we shouldn't be able to trigger copy/paste in the first place in the smartphone FTU
Tim, can you help out with this selection bug?
Flags: needinfo?(timdream)
Ting-Yu, could you handle this? Thanks!
Flags: needinfo?(timdream) → needinfo?(tlin)
The root cause is similar to bug 1228151 where AppTextSelectionDialog is not being loaded as a component into FTU. To make copy/paste work, app needs to load AppTextSelectionDialog as a sub-component in [1].

I've tried to launch FTU though WebIDE, and copy/paste works as normal. I'm totally foreign to Gaia starup process. Does FTU being loaded differently when it's the first time use? Does FTU have sub-component mechanism so that AppTextSelectionDialog can be added?

If we decide not to use copy/paste in FTU, FTU should set "-moz-user-select: none" in CSS so that no selection is possible. Hence no caret or dialog will show.

[1] https://github.com/mozilla-b2g/gaia/blob/0f75fc15737c5185fbc8a3b82588ce2c23e01ade/apps/system/js/app_window.js#L845
Flags: needinfo?(tlin) → needinfo?(sfoster)
> If we decide not to use copy/paste in FTU, FTU should set "-moz-user-select:
> none" in CSS so that no selection is possible. Hence no caret or dialog will
> show.

As I said in Comment #1, the bug here is that we already set -moz-user-select: none in the FTU, yet recently text has become selectable. See: https://github.com/mozilla-b2g/gaia/blob/master/apps/ftu/style/style.css#L1:L3

I'm flagging for a regression window.
Flags: needinfo?(sfoster)
Keywords: regressionwindow-wanted

Updated

2 years ago
QA Contact: jthomas

Comment 6

2 years ago
Caused by changes made in Bug 1147329

Mozilla Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20150726203545
Gaia: ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gecko: 5f2e5a9fb54d
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20150726205745
Gaia: ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gecko: d4b6f85c0d42
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working gaia / First Broken gecko - This issue DOES occur with broken Gecko.
Gaia: ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gecko: d4b6f85c0d42

Last Working gecko / First Broken gaia - This issue does NOT occur with with Broken Gaia.
Gecko: 5f2e5a9fb54d
Gaia: ade1ef5249cfab921e00ed67b30f3d03c2e24b5e

Mozilla Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5f2e5a9fb54d&tochange=d4b6f85c0d42
Blocks: 1147329
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Seems cut/copy/paste (CCP) doesn't work while launching FTU from a flash device. The problem should be very similar with Bug 1228151. So, ensuring that "AppTextSelectionDialog" is properly installed while launching FTU should be a fix.

However, it is very hard to debug, because the code flow are different between launching FTU from a newly flashed device and that from settings->developer->launch FTU. CCP doesn't work in the former, but it works in the latter.

I think making the two code flows being consistent could be a fix. If it's not possible, then we'll have to install "AppTextSelectionDialog" while launching FTU from a flash device.
I just got the info from Bug 1252427. It seems we're removing FTU app.
Depends on: 893583, 1252427
(In reply to Jeremy Chen [:jeremychen] UTC+8 from comment #8)
> I just got the info from Bug 1252427. It seems we're removing FTU app.

Yeah, and if this issue is only occuring on the FTU app there's no sense in spending more time on it. Thanks for the diagnosis though we'll need to keep an eye out for similar issues elsewhere. I'll wontfix this one for now though.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.