Closed Bug 1231414 Opened 4 years ago Closed 7 months ago

RTCPeerConnection.addTrack should not require a stream to be passed

Categories

(Core :: WebRTC, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox45 --- wontfix
firefox67 --- fixed

People

(Reporter: bzbarsky, Assigned: bwc)

References

Details

(Keywords: dev-doc-complete, Whiteboard: [spec])

Attachments

(2 files)

Per https://github.com/w3c/webrtc-pc/issues/288 calling addTrack with no streams should be OK.
Component: DOM → WebRTC
See Also: → 1271669
Rank: 25
Priority: -- → P2
Whiteboard: [spec]
Mass change P2->P3 to align with new Mozilla triage process.
Priority: P2 → P3
Duplicate of this bug: 1451784
Rank: 25 → 15
Priority: P3 → P2

This is turning into a major headache with web-platform-tests, requiring lots of tests (that aren't really testing addTrack) to be disabled.

Assignee: nobody → docfaraday
See Also: → 1514670

Review ping.

Flags: needinfo?(jib)

All reviews here look accepted.

Flags: needinfo?(jib)
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/918f7a08c59b
Part 1: Allow addTrack without a stream argument. r=jib,smaug
https://hg.mozilla.org/integration/autoland/rev/6be475d0d9b8
Part 2: Mark some wpt as expected to succeed. r=jib
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Documentation updated:

I've made substantial revisions to the article on addTrack() to cover this and to explain in more detail the relationship between the tracks and streams across a peer connection. This would definitely benefit from a review:

https://developer.mozilla.org/en-US/docs/Web/API/RTCPeerConnection/addTrack

I've also made affiliated revisions to the following articles. Some are error corrections, some are clarifications, and there are a few additions of missing details:

https://developer.mozilla.org/en-US/docs/Web/API/RTCPeerConnection/addStream
https://developer.mozilla.org/en-US/docs/Web/API/MediaStream/MediaStream
https://developer.mozilla.org/en-US/docs/Web/API/RTCTrackEvent

Since this is a bug fix, I don't think it warrants a BCD update. If there's disagreement, it could be added as a note -- I'm not sure adding a "feature" row for this makes sense given that it's a bug fix.

Added to Firefox 67 for developers.

You need to log in before you can comment on or make changes to this bug.