Closed Bug 1231568 Opened 5 years ago Closed 4 years ago

inbox.google.com never finishes loading in latest inbound builds

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox44 --- unaffected
firefox45 - affected

People

(Reporter: rick3162, Unassigned)

References

Details

(Keywords: regression)

To reproduce:
- install firefox 45.0a1 x64 inbound 2015-12-09 (fresh profile) in win10 x64 (e10s enabled) 
- open inbox.google.com and login
- Inbox starts loading but never finishes: https://i.imgur.com/DohD29r.jpg

There's no relevant entry in Web Console while this occurs.
The issue also occurs with e10s disabled.


Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d55129069a1f56f63573282911ad2dac17d6e7b1&tochange=94f4cfa98356714223ee71774f27a9153b6ab188
Blocks: 1071646
Status: UNCONFIRMED → NEW
Ever confirmed: true
Inbox uses a certain try-catch pattern which breaks with Annex B block scoping, see [1] for more information.

[1] https://github.com/tc39/ecma262/issues/162
Confirm this bug in openSUSE 13.2, x64
Confirming this bug on Nightly on OSX.
Confirming this bug on Nightly on Win 10.
Duplicate of this bug: 1232215
Duplicate of this bug: 1232315
Component: General → JavaScript Engine
Product: Firefox → Core
(In reply to André Bargull from comment #1)
> Inbox uses a certain try-catch pattern which breaks with Annex B block
> scoping, see [1] for more information.
> 
> [1] https://github.com/tc39/ecma262/issues/162

Interesting. Are we going to use a workaround for inbox (and other GWT apps, I guess) or what's the plan?
[Tracking Requested - why for this release]:

Bug 1071646 broke Google Inbox in Nightly 45.
Backed out for now: https://hg.mozilla.org/integration/mozilla-inbound/rev/d2bec6ed7b30

The plan is to wait for GWT and Inbox to fix their code. Chrome is waiting on the same thing. I will try to reland when that is fixed.
Shu-yu, could you backout also the change in aurora (45)? 
FYI, I pinged a friend working at Google on GWT.
Flags: needinfo?(shu)
(In reply to Sylvestre Ledru [:sylvestre] from comment #10)
> Shu-yu, could you backout also the change in aurora (45)? 
> FYI, I pinged a friend working at Google on GWT.

I think this was backed out from 45 and relanded in 46, but let's wait for shu to confirm.
Yes, it was backed out then relanded.
Flags: needinfo?(shu)
It has been fixed on the inbox side, untracking it.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
I think this is happening again starting with at least 51.0a2 up until the latest 52.0a2. I'm getting a "Loading" spinner in the lower left corner as described in the initial description that never finishes loading. Seeing this on Ubuntu 14.04, 16.04 and 16.10.
You need to log in before you can comment on or make changes to this bug.