Implement a Storage editor

RESOLVED DUPLICATE of bug 1031192

Status

RESOLVED DUPLICATE of bug 1031192
3 years ago
4 months ago

People

(Reporter: lrbabe, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151210030212




Expected results:

The Storage inspector is rather frustrating: I can see what keys are stored using cookies, localStorage and other storage... and that's pretty much it!
Most of the time, the values are too long to be displayed entirely in the table or tree view, so they are displayed with "...", and there is no way to inspect or copy the actual value : ( 
The inability to edit those values is equally frustrating.
(Reporter)

Updated

3 years ago
Component: Untriaged → Developer Tools: Storage Inspector
Indeed!  We are working on editing support, which I expect will also involve tweaks to the UI as well to all the editing.  I believe bug 1031192 covers what you're describing here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1031192
(In reply to J. Ryan Stinnett [:jryans] (use ni?) (at work week until Dec. 14) from comment #1)
> to the UI as well to all the editing.

"allow the editing"

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.