[FlameKK] Video is not playing correctly in video app

VERIFIED DUPLICATE of bug 1232348

Status

VERIFIED DUPLICATE of bug 1232348
3 years ago
3 years ago

People

(Reporter: MaxIvanov, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.5 unaffected, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Video clips is not start playing automatically. Sometimes it is completely impossible to play any video.

Repro Steps:
1) Update a Flame to 20151214030209
2) Have some video clip on your phone
3) Open video app and play any video

Actual:
Video clips is not start playing automatically, sometimes it is impossible to play video clip at all.

Expected:
Video clips start automatically and play without issues

Environmental Variables:
Device: Flame 2.6
Build ID: 20151214030209
Gaia: ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gecko: 99137d6d4061f408ae0869122649d8bdf489cc30
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: (7/10)
See attached: (video clip)
https://youtu.be/8yhRNkL-gp4
(Reporter)

Comment 1

3 years ago
This does not happen on Aries 2.6 and Flame 2.5

Device: Aries 2.6
Build ID: 20151214121335
Gaia: ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gecko: 99137d6d4061f408ae0869122649d8bdf489cc30
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Flame 2.5
Build ID: 20151214083757
Gaia: 062e0fa48c1b5d5156f6911a5a4519128fac3231
Gecko: d76a9f65b6ba2ab587d3a0fb5119773ba68720a0
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.5: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.6-Daily-Testing]
Major regression that is a smoketest blocker.  Let's get a window here.
blocking-b2g: --- → 2.6?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Keywords: qaurgent, regressionwindow-wanted, smoketest
Last Working
Device: Flame 2.6
BuildID: 20151211074133
Gaia: d886e152b42e557db612470d3417fe2947cbdeee
Gecko: ee132b90ad4b11b03c4dcc5b21bc636ef11bbe66
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken
Device: Flame 2.6
BuildID: 20151211081830
Gaia: d886e152b42e557db612470d3417fe2947cbdeee
Gecko: eb3d458624eb3a62e8aebfaed322a63314153d3e
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ee132b90ad4b11b03c4dcc5b21bc636ef11bbe66&tochange=eb3d458624eb3a62e8aebfaed322a63314153d3e

Caused by changes made in Bug 1214148.
Blocks: 1214148
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qaurgent, regressionwindow-wanted
Andrea this smoketest blocker seems to have been caused by the changes for bug 1214148.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(amarchesini)
Flags: needinfo?(ktucker)
Flags: needinfo?(amarchesini)
Same regression window as bug 1232363.
Status: NEW → RESOLVED
blocking-b2g: 2.6? → ---
Last Resolved: 3 years ago
Keywords: smoketest
Resolution: --- → DUPLICATE
Duplicate of bug: 1232363
Keywords: verifyme
This bug has been verified as pass on latest build of Flame KK master 512mb by the STR in comment 0.
Actual results: Video clips start automatically and play without issues.
See attachment: verified_Flame_master.3gp
Reproduce rate: 0/10

Device: Flame KK master(pass)
Build ID               20151215150203
Gaia Revision          ee43a95f2bbe39c5ac8c9fcdec76749a56c02f2e
Gaia Date              2015-12-15 04:30:46
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cb66ffeb6725e8344818e8e2f707ae2eaeb953b4
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151215.184537
Firmware Date          Tue Dec 15 18:45:49 EST 2015
Firmware Version        V18D V4
Bootloader             L1TC000118D0
Created attachment 8698831 [details]
Verified video: Verified_Flame_master.3gp
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: affected → verified
Keywords: verifyme
Status: RESOLVED → VERIFIED

Updated

3 years ago
Duplicate of bug: 1232348
You need to log in before you can comment on or make changes to this bug.