Closed Bug 1232445 Opened 6 years ago Closed 6 years ago

Reader Mode: lack of RTL support

Categories

(Toolkit :: Reader Mode, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1173548
Tracking Status
fennec - ---

People

(Reporter: tomer, Unassigned)

References

()

Details

(Keywords: rtl)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #800188 +++

When watching a page in an RTL language and switching to Reader Mode, Firefox for Android should respect the directionality of every page element when reformatting the page. Currently we don't do so, which make the Reader Mode non-functional when content is in one of the RTL languages…



Attached is a screenshot of the first link from bug 800188 comment 37.

The expected result is having the text flow from the right edge of the screen and not left aligned.



*** This is a clone of bug 800188, as requested on bug 800188 comment 39. Please note that the previous bug has some activity that is currently missing here.
this is also relevant for firefox for windows
Whiteboard: [mentor=lucasr][lang=css][lang=js] → [lang=css][lang=js]
No longer blocks: Persian, 1128124
tracking-fennec: --- → ?
No longer depends on: 800188
Whiteboard: [lang=css][lang=js]
tracking-fennec: ? → -
Component: Reader View → Reader Mode
Product: Firefox for Android → Toolkit
(In reply to Simon Montagu :smontagu from comment #2)
> Dupe of bug 1173548?

Yes, looks like it.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1173548
You need to log in before you can comment on or make changes to this bug.