Open Bug 285718 (Persian) Opened 16 years ago Updated 3 months ago

[META] Tracker for Persian support in Mozilla applications

Categories

(Core :: Internationalization: Localization, defect)

defect
Not set
normal

Tracking

()

ASSIGNED

People

(Reporter: zwnj, Assigned: zwnj)

References

(Depends on 23 open bugs)

Details

(Keywords: meta)

Attachments

(4 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Tracking bug for Persian

Reproducible: Always

Steps to Reproduce:
i don't think two separate tracking bugs are needed for this?

*** This bug has been marked as a duplicate of 108492 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Roozbeh has not updated/managed his bug tracker for long time.  I wanna to close
that one and open a new one.  Because of new mozilla's buzilla policy, I cannot
do everything in that one.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Would someone assign this bug to me, please?
Assignee: chofmann → behnam
*** Bug 108492 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → ASSIGNED
Depends on: 268113, 274152, 284927
Ever confirmed: true
QA Contact: chofmann → behnam
Summary: Meta Bug: Behnam's tracking bug for Persian → Meta Bug: Tracking bug for Persian
Depends on: 69230
Depends on: 204767
Keywords: meta
Depends on: 199519
Depends on: 204272, 260663
Depends on: 296605
Depends on: 296689
Depends on: 218823, 224685
Depends on: 298004
Depends on Bug 231701 - format=flowed DelSp=yes not supported (RFC 3676)

Because:  Lake of line-break/paragraph-separator detection cause many BiDi
problems, i.e. mail client fails to auto-align paragraph.
Depends on: 231701
No longer depends on: 231701
Depends on: 231701
Bug 290351 - Registration of Persian (fa-IR) Firefox localization
Depends on: 290351
Alias: Persian
Bug 177508 - Internationalization - ALT-key / underlined keyboard shortcuts |
mnemonics | access keys do not work in all input locales
Depends on: 177508
Bug 301896 -- Layout: BiDi Hebrew & Arabic -- Tab selection with Alt+NUM is
reversed in BiDi layouts
Depends on: 301896
Bug 301897 -- Internationalization -- Alt+NUM (tab jumping) cannot be localized
Depends on: 301897
Depends on: 304523
Bug 304523 -- inline html tags break arabic joining
Bug 69230 -- Accelerators should not be affected by keyboard group/level
Depends on: 305602
Bug 305602 -- Bidi: Difficult to select to end of line using the mouse when line
ends with reverse-direction text
Bug 236135 -- word-internal tags force word-final shaping in Arabic
Depends on: 236135
Bug 162081
Wrong letter is underlined as accesskey / mnemonic when widget direction is RTL
Depends on: 162081
Bug 280936 -- In right-to-left languages, char zwnj (U+200C) is not handled
Depends on: 280936
From MetaNet:
Bug #121633 - [bidi]reflowinlineframes accumulates margins on the right side.
Bug #237370 - unexpected behavior of borders in RTL text
Bug #258928 - misplaced padding of inlines which are RTLed or have RTL text
Bug #258949 - padding not applied or incorrectly applied to :after pseudoelement
Bug #98157 - Caret does not have bidi marker in certain dialog boxes
Bug #174470 - [BC] Bidi : Border-collapse property in RTL direction is not working correctly
Bug #206089 - Tiny layout problem in Arabic or Hebrew (Right to Left) language
Bug #121633 - [bidi]reflowinlineframes accumulates margins on the right side.
Bug #6976 - Horizontal scrollbar is missing. {was: "create scrollbar for / allow scrolling to overflow top (above) / left of container (Left side of the page is cut)"}
Bug #99823 - Layout of Arabic (shaped) text is faulty
Depends on: 174470
Good: (green)
- Bidi icons in toolbar.
- Bidi marked XUL. (translation)
- 

Bad: (red)
- Font problems. (without pango)
Bad: (red)
- No file name, address, etc detection makes status-bar buggy with texts and addresses.
No more good (grean) things. :(

Bad: (red)
- Bad font selection (pango) for parenthesis of shortcuts.
- ZWNJ have been removed in XUL texts. (Bug 280936)
- GTK2-based doesn't work well with RTL XUL. (I think we don't have such problems in Win32 backend)
- And the well-known status bar problem with RTL languages. (Filed bug?)
Good: (green)
- Arabic HARKATs are placed well with pango enabled.

Not sure: (gray)
- ZWNJ problems in translations. (see also Bug 280936)  I'm not what the bug is yet!  The first appearance of "بارگیری‌ها" doesn't have ZWNJ displayed, and the second one does!  I'm going to take a look deep on it.

Bad: (red)
- Underline breaks Arabic joining.  Note that we didn't have this problem with Fx1.0.  As you can see, there's no problem in XUL menus too.  Now it's a new problem!
Depends on: 347502
Depends on: NewThemeRTL
Depends on: 347505
Depends on: 265030
Depends on: 347510
Depends on: 347514
Depends on: 347515
Depends on: 347621
Depends on: 347632
Depends on: 347634
Depends on: 297790
Depends on: 151374
Depends on: 330863
Depends on: 192767
Depends on: 265276
Depends on: numbers
Depends on: 347977
Depends on: 347981
Depends on: 348221
Depends on: 348233
Depends on: 348712
Depends on: BidiKeyboardGtk2
Depends on: 348728
Depends on: 349154
Depends on: 349176
Depends on: 349180
Depends on: 349193
Depends on: Persian-Fx2.0
No longer depends on: Persian-Fx2.0
Summary: Meta Bug: Tracking bug for Persian → [META] Tracking bug for Persian
Depends on: Persian-Fx2.0
Depends on: 349904
Depends on: 350029
Depends on: 350594
Depends on: 350595
Depends on: 350596
Depends on: 350597
Depends on: 350605
Depends on: 350611
Depends on: 350764
Attachment #231879 - Attachment is obsolete: true
Attachment #231880 - Attachment is obsolete: true
Attachment #232152 - Attachment is obsolete: true
Attachment #232154 - Attachment is obsolete: true
No longer depends on: 347621
Depends on: 351562
Depends on: 154632
Depends on: BidiCaret
Depends on: 353682
Depends on: Unicode5Joining
Depends on: ArabicLogotype
Depends on: 390140
Depends on: fx20-fa
Depends on: land-fa
Depends on: 390141
Depends on: 397900
Depends on: m.d.l10n.fa
Depends on: 398998, 398999, 399000, 399001, 399003
No longer depends on: 398998, 398999, 399000, 399001, 399003
Duplicate of this bug: 314969
Duplicate of this bug: 289290
Depends on: example.test
Depends on: 397803
Depends on: 399217
Depends on: 404149
Depends on: 312436
Depends on: IDN-dot-IR
Depends on: 402247
Depends on: Persian-Fx3.5
Depends on: Persian-AddrBar
QA Contact: bugs+behnam → persian.fa
Depends on: 417489
Depends on: Persian-Enhance
Depends on: 417899
Depends on: 402607
Depends on: fx35-l10n-fa
Depends on: 428492
Depends on: 234856
Depends on: 427957
Depends on: 435856
Summary: [META] Tracking bug for Persian → [META] Tracker for Persian suuport in Mozilla applications
Depends on: 390028
Summary: [META] Tracker for Persian suuport in Mozilla applications → [META] Tracker for Persian support in Mozilla applications
Depends on: 353087
No longer depends on: 347510
Depends on: 484117
Adding the dependencies removed from bug 415597 to this bug for tracking purposes.
Depends on: 312891
No longer depends on: 349154
Depends on: 800188
Depends on: 1232445
Component: Tracking → Internationalization
QA Contact: chofmann
Component: Internationalization → Internationalization: Localization
You need to log in before you can comment on or make changes to this bug.