Closed Bug 1232647 Opened 6 years ago Closed 6 years ago

Downloads complete icon (blue arrow) in hamburger menu is gone after a download

Categories

(Firefox :: Theme, defect)

45 Branch
Unspecified
Windows 10
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 46
Tracking Status
firefox45 --- verified
firefox46 --- verified

People

(Reporter: Fanolian+BMO, Assigned: Gijs)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20151214122242

Steps to reproduce:

1. In a new profile, move the Downloads button into hamburger menu.
2. Download a file. 


Actual results:

The blue arrow is gone. See attachment.


Expected results:

There should be a blue arrow for Downloads.

Note:
1. If the Downloads button stays on toolbar, the arrow displays correctly.
2. If the download animation (a grey arrow flying to toolbar/hamburger menu) is not triggered, start another download will fix it. This may happen on first download, when I first move the Downloads button into hamburger menu, or when I download a file shortly after starting Nightly (within ~10s).
From Mozregression:

Last good Nightly: 2015-11-09
First bad Nightly: 2015-11-10
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e2a910c048dc82fc3be53475f18e7f81f03e377b&tochange=cc473fe5dc512c450634506f68cbacfb40a06a23

Further bisection:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=2bd857903ba9c2f5779fcb32f24673131a405192&tochange=17194b40e1df3157b5f586037685c7dbc2bd2b42
Blocks: 1216955
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Theme
OS: Unspecified → Windows
Which version of Windows are you using? Comment #0 is Windows 10, but the screenshot looks like it isn't win10.

If you open this file by putting the URL in the location bar:

chrome://browser/skin/downloads/download-glow-menuPanel.png

do you see the blue arrow?

If not, can you open about:preferences, open the web console (ctrl-shift-k), and run:

manifests = Components.manager.getManifestLocations();
for (let i = 0; i < manifests.length; i++) {
  console.log(manifests.queryElementAt(i, Components.interfaces.nsIURI).spec);
}

and paste the output in the bug, please?
Flags: needinfo?(Fanolian+bugzilla)
Gah, sorry, never mind, I thought we updated the menu panel icons on win10 as well, but we don't seem to have done - I can reproduce on my win10 VM.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(Fanolian+bugzilla)
OS: Windows → Windows 10
This is because WINDOWS_AERO was no longer defined after bug 706103, so all versions of Windows were using that image, and now nobody except =<6.1 is getting the right image (because the override only applies there). So win8 and win10 are affected.

It seems bug 706103 removed the include of the non-XPVista7-suffixed file packaged for aero (so win8+) from jar.mn without putting it back, and I missed that in review.

Dão, does that look right?

https://dxr.mozilla.org/mozilla-central/source/browser/themes/windows/downloads/download-glow-menuPanel.png

is still there, but it doesn't seem like we ever package it.
Blocks: 706103
Flags: needinfo?(dao)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(dao)
Keywords: regression
This seems to fix things for me.
Attachment #8698446 - Flags: review?(dao)
Comment on attachment 8698446 [details] [diff] [review]
package default glow icon on Windows again,

nit: please put the download-glow-menuPanel.png entry above the download-glow-menuPanel-XPVista7.png one
Attachment #8698446 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/b5336b2a4e6e
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
Comment on attachment 8698446 [details] [diff] [review]
package default glow icon on Windows again,

Approval Request Comment
[Feature/regressing bug #]: bug 1216955
[User impact if declined]: download icon disappears after a successful download when the button is in the menu panel, on win8 and win10
[Describe test coverage new/current, TreeHerder]: none, styling issue only :-(
[Risks and why]: slim to none, just packaging a file we should have been packaging all along
[String/UUID change made/needed]: no
Attachment #8698446 - Flags: approval-mozilla-aurora?
Comment on attachment 8698446 [details] [diff] [review]
package default glow icon on Windows again,

Obvious visual regression, taking it
Attachment #8698446 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Whiteboard: [good first verify]
Reproduced the bug in 45.0a1 (2015-12-14) on windows 10 x64 as Comment 0

Verified as fixed with latest firefox aurora 45.0a2 (Build ID: 20160114004007)
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0 

And latest firefox nightly 46.0a1 (Build ID: 20160114060719)
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
QA Whiteboard: [good first verify] → [good first verify][testday-20160115]
I have reproduced this bug in 46.0a1 (2015-12-15) on windows 8.1 (64 bit)

Bug is now verified as fixed latest Firefox Developer edition 45.0a2 (2016-01-15)
Build Id:20160115004002
User agent:Mozilla/5.0 (Windows NT 6.3; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.