Closed Bug 123317 Opened 23 years ago Closed 22 years ago

High ASCII data is being cut off at certain characters during form submission

Categories

(Core :: DOM: Core & HTML, defect, P2)

x86
All
defect

Tracking

()

VERIFIED FIXED
mozilla1.1alpha

People

(Reporter: zedorg, Assigned: john)

References

()

Details

(Keywords: dataloss, intl, regression)

Attachments

(1 file)

In textarea or input type text if the value contains some of these entities: &
ocirc; or & otilde; .... mozilla (tested under win2k, under linux worked) would
not send the data, it breaks before these chars. I make a test page, so you
check it. This is very important, cause who use mozilla and this chars under
windows, can not send the text they want. It can be fixed from html or it is a
real mozilla bug?
Both seemed to work for me with build 2002020106-0.9.8/WinNT4.

Reporter: what build ID are you using, and does it still happen with a more
recent build?
win2k: regional setting: English [UK], language Central Europe
With mozilla 20011128 rv.0.9.4 in NS6/6.2.1 these chars will be '?', but sended.
With: 2002013003, 2002020208, 2002020318 (swg-math), release 0.9.7 (2001122106)
the problem is available.
The problem seem to be the character coding: In case: ISO 8859-2, these chars
wont go, but change the charset to ISO 8859-1 will. How can it be?:) In input
value there are html entities and not special chars.
Ah! Confirmed - 2002020106-0.9.8/WinNT4, when set to ISO-8859-2, shows the
behaviour described. My 'WFM' was with it set to ISO-8859-1. How odd ...
*** Bug 123386 has been marked as a duplicate of this bug. ***
Confirming, setting os to all, See coments in Bug 123386, and another testcase
is http://bubblegum/vladimire/tests/ugntxt03.html
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss, intl
OS: Windows 2000 → All
Priority: -- → P2
Vladimir: would you be able to please put your testcase on an external server,
or attach it? Thanks :-)

Also, bug 123386 has a much more general summary than this bug ... might be
worth changing it.
Summary: Some latin 2 chars with html entities won't work in textarea and text input → High ASCII data is being cut off at certain characters during form submission
nominating nsbeta1 due to severity. 
Keywords: nsbeta1
Reassigning to jkeiser
Assignee: alexsavulov → jkeiser
Target Milestone: --- → mozilla1.0
Marking nsbeta1-.
Keywords: nsbeta1nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.1
Keywords: regression
This is breaking our automation testing results, cuts off tables which breaks
the parser scripts. Changing severity to blocker.
Severity: major → blocker
I am thinking bug 117422 is a dup of this.  Let's see what happens when ftang
checks in, shall we?
Depends on: 117422
*** Bug 128137 has been marked as a duplicate of this bug. ***
This was fixed by 117422.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
Verifying on
windows 98 build 2002-03-01-03-trunk
and linux RedHat build 2002-03-01-09-trunk
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: