TB uploads fail with "Can't open file '/builds/slave/tb-c-cen-lx-ntly-0000000000000/build/mach'"

RESOLVED DUPLICATE of bug 1233577

Status

--
blocker
RESOLVED DUPLICATE of bug 1233577
3 years ago
3 years ago

People

(Reporter: aleth, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
All OS.

 Executing: ['python', '/builds/slave/tb-c-cen-lx-000000000000000000/tools/buildfarm/utils/graph_server_post.py', '--server', 'graphs.mozilla.org', '--selector', '/server/collect.cgi', '--branch', 'Thunderbird', '--buildid', "/tools/buildbot/bin/python: can't open file '/builds/slave/tb-c-cen-lx-000000000000000000/build/mach': [Errno 2] No such file or directory", '--sourcestamp', "/tools/buildbot/bin/python: can't open file '/builds/slave/tb-c-cen-lx-000000000000000000/build/mach': [Errno 2] No such file or directory", '--resultsname', 'TB_Linux_comm-central', '--properties-file', 'properties.json', '--timestamp', '1450450015']
 results not added, response: 
 '/tools/buildbot/bin/python: can't open file '/builds/slave/tb-c-cen-lx-000000000000000000/build/mach' failed string validation

and

 Running post-upload command: post_upload.py --tinderbox-builds-dir comm-central-linux -b comm-central -p thunderbird -i /tools/buildbot/bin/python: can't open file '/builds/slave/tb-c-cen-lx-ntly-0000000000000/build/mach': [Errno 2] No such file or directory --revision 62a362aec62f --release-to-tinderbox-dated-builds --release-to-latest-tinderbox-builds --release-to-latest --release-to-dated
 Traceback (most recent call last):
   File "/builds/slave/tb-c-cen-lx-ntly-0000000000000/build/mozilla/build/upload.py", line 328, in <module>
     package=options.package, verbose=True)
   File "/builds/slave/tb-c-cen-lx-ntly-0000000000000/build/mozilla/build/upload.py", line 232, in UploadFiles
     output = DoSSHCommand('%s "%s" %s' % (post_upload_command, path, file_list), user, host, port=port, ssh_key=ssh_key)
   File "/builds/slave/tb-c-cen-lx-ntly-0000000000000/build/mozilla/build/upload.py", line 96, in DoSSHCommand
     output = f(cmdline, stderr=STDOUT).strip()
   File "/builds/slave/tb-c-cen-lx-ntly-0000000000000/build/mozilla/python/redo/redo/__init__.py", line 185, in _retriable_wrapper
     **retry_kwargs)
   File "/builds/slave/tb-c-cen-lx-ntly-0000000000000/build/mozilla/python/redo/redo/__init__.py", line 140, in retry
     return action(*args, **kwargs)
   File "/tools/python27/lib/python2.7/subprocess.py", line 573, in check_output
     raise CalledProcessError(retcode, cmd, output=output)
 subprocess.CalledProcessError: Command '['ssh', '-o', 'IdentityFile=~/.ssh/tbirdbld_dsa', 'tbirdbld@upload.tbirdbld.productdelivery.prod.mozaws.net', 'post_upload.py --tinderbox-builds-dir comm-central-linux -b comm-central -p thunderbird -i /tools/buildbot/bin/python: can\'t open file \'/builds/slave/tb-c-cen-lx-ntly-0000000000000/build/mach\': [Errno 2] No such file or directory --revision 62a362aec62f --release-to-tinderbox-dated-builds --release-to-latest-tinderbox-builds --release-to-latest --release-to-dated "/tmp/tmp.C5CNzyrrih/" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.tar.bz2" "/tmp/tmp.C5CNzyrrih/update/thunderbird-46.0a1.en-US.linux-i686.complete.mar" "/tmp/tmp.C5CNzyrrih/linux-i686/xpi/thunderbird-46.0a1.en-US.langpack.xpi" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.common.tests.zip" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.cppunittest.tests.zip" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.xpcshell.tests.zip" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.mochitest.tests.zip" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.talos.tests.zip" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.reftest.tests.zip" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.web-platform.tests.zip" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.crashreporter-symbols.zip" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.txt" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.json" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.mozinfo.json" "/tmp/tmp.C5CNzyrrih//test_packages.json" "/tmp/tmp.C5CNzyrrih//jsshell-linux-i686.zip" "/tmp/tmp.C5CNzyrrih/host/bin/mar" "/tmp/tmp.C5CNzyrrih/host/bin/mbsdiff" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.checksums" "/tmp/tmp.C5CNzyrrih//thunderbird-46.0a1.en-US.linux-i686.checksums.asc"']' returned non-zero exit status 1
 make[1]: *** [upload] Error 1
(Reporter)

Comment 1

3 years ago
Looks like an incorrect path somewhere.

Comment 2

3 years ago
see bug 1233577
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1233577
(Reporter)

Comment 4

3 years ago
Thanks Wayne. Please add such bustage bugs to the etherpad if you are aware of them to avoid duplications!

Comment 5

3 years ago
Thanks for the reminder. I've never paid much attention to the etherpad because, although it's been a very good thing for you all who are working on these, I've found the structure and amount of content in https://public.etherpad-mozilla.org/p/thunderbird-tree-status  (plus hard to track because one does not get notified when people update it)  

Has it been simplified in recent weeks?

Comment 6

3 years ago
(lost context)

I've found the structure and amount of content in https://public.etherpad-mozilla.org/p/thunderbird-tree-status  to be daunting at times - time consuming to parse and follow
(plus hard to track change because one does not get notified when people update it)
You need to log in before you can comment on or make changes to this bug.