PDFJS draws big black ellipses over pictures when HWA is enabled

RESOLVED DUPLICATE of bug 858128

Status

()

Firefox
PDF Viewer
RESOLVED DUPLICATE of bug 858128
2 years ago
10 months ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox42 affected, firefox43 affected, firefox44 affected, firefox45 affected, firefox46 affected, firefox-esr38 affected)

Details

(URL)

Attachments

(1 attachment)

79.52 KB, application/x-download
Details
(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20151217030207
STR:
1. Enable hardware acceleration in Firefox, restart the browser
2. Open "pdf_file_1" below in PDFJS

Result:       There're black ellipses drawn over images on the 1st page and on the 9th page 
Expectations: There should be no black ellipses

Note:   I opened that .pdf file in local PDFJS (viewer.html) - it still exposes the issue,
        but only in Firefox, not in GoogleChrome with enabled HWA. So it looks like firefox bug.
        Some detailed info from PDFJS developers is required.

Links:
> pdf_file_1       https://dl.dropboxusercontent.com/s/9vc5qlydskiwu6g/16_The_impact_of_transport_policies_on_railroad_intermodal_freight_competitiveness__The_case_of_Belgium.pdf?dl=0
> screenshot       https://dl.dropboxusercontent.com/s/tye9y9gl0ta4dop/screenshot%201%20-%20pdfjs%20draws%20a%20big%20black%20ellipses%20over%20pictures%20when%20HWA%20enabled.png?dl=0
> about:support    https://dl.dropboxusercontent.com/s/wzj99pequngf7oz/Troubleshooting%20Information%202015.12.20%2002-10-12.xht?dl=0
> 
> Dropbox folder   https://www.dropbox.com/sh/18iujohwvcthqcw/AACtQQ4ahL5AKU9NftUUmrbLa?dl=0
(Reporter)

Comment 1

2 years ago
It's reproducible since at least firefox 28
status-firefox42: --- → affected
status-firefox43: --- → affected
status-firefox44: --- → affected
status-firefox45: --- → affected
status-firefox-esr38: --- → affected

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 858128
(Reporter)

Comment 3

a year ago
Clearing CC-list to avoid bug spam
I'll use this bug for a small test, because I can't do it anywhere else.
Comment hidden (spam)
Comment hidden (spam)
(Reporter)

Comment 6

10 months ago
test
(Reporter)

Updated

10 months ago
Blocks: 1326593
(Reporter)

Updated

10 months ago
See Also: → bug 1326593
(Reporter)

Updated

10 months ago
No longer blocks: 1326593
See Also: bug 1326593
You need to log in before you can comment on or make changes to this bug.