[Dialer] Cancel button is sized wrong in action menu after tap the menu of matched phone number.

RESOLVED DUPLICATE of bug 1225047

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1225047
2 years ago
2 years ago

People

(Reporter: Alissa(leave from Mozilla), Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-master affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8700508 [details]
Flamekk2.5.png

[1.Description]:
[Flamekk2.5&master][Arieskk2.5&master]There are some contacts saved, try to input the number which are contained in more than one contacts, tap the menu button to select, the cancel button is sized wrong in action menu after tapping the menu of matched phone number.
See attachment:Flamekk2.5.png

[2.Testing Steps]: 
Precondition: There are some contacts which contain same digits in phone number, e.g.: 10080,10086,10010
1.Launch dialer.
2.Input the phone number,e.g.:100
3.The recommended contact will be displayed above the keyboard.
4.Tap the menu at right and check the contact list.

[3.Expected Result]: 
4.The Cancel button is in a proper size, consistent with other cancel buttons.

[4.Actual Result]: 
4.You can see the cancel button is displayed in action menu.

[5.Reproduction build]: 
Device: Flamekk mastser eng[Affected]
Build ID               20151220150206
Gaia Revision          d069027f9af6f835ef869f1f01b52339e5a3f423
Gaia Date              2015-12-18 08:50:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/388bdc46ba51ee31da8b8abe977e0ca38d117434
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151220.191933
Firmware Date          Sun Dec 20 19:19:45 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flamekk v2.5 user[Affected]
Build ID               20151218180935
Gaia Revision          eeed1451e0e48b63abe3199e4d6906adc2a762d2
Gaia Date              2015-12-17 14:53:36
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/766600655dfb1b67c380b9da4f4b19acb505a858
Gecko Version          44.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151218.172320
Firmware Date          Fri Dec 18 17:23:30 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries kk v2.5 dogfood[Affected]
Build ID               20151218184045
Gaia Revision          eeed1451e0e48b63abe3199e4d6906adc2a762d2
Gaia Date              2015-12-17 14:53:36
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/766600655dfb1b67c380b9da4f4b19acb505a858
Gecko Version          44.0
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151218.174305
Firmware Date          Fri Dec 18 17:43:13 UTC 2015
Bootloader             s1

Device: Aries KK master(Affected)
Build ID               20151219131630
Gaia Revision          d069027f9af6f835ef869f1f01b52339e5a3f423
Gaia Date              2015-12-18 08:50:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/388bdc46ba51ee31da8b8abe977e0ca38d117434
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151219.123525
Firmware Date          Sat Dec 19 12:35:33 UTC 2015
Bootloader             s1

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

2 years ago
Blocks: 1196268
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
[Blocking Requested - why for this release]: Although the functionality is not broken, the fix seems easy, similar to bug 1232594.
blocking-b2g: --- → 2.5?
This is being resolved in bug 1234139.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1225047
blocking-b2g: 2.5? → ---
You need to log in before you can comment on or make changes to this bug.