Remove "Don't ask me again" footgun option from the "enable DRM" info bar notification

RESOLVED FIXED in Firefox 45

Status

()

Firefox
General
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: cpeterson, Assigned: cpeterson)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 47
Points:
---

Firefox Tracking Flags

(firefox43 affected, firefox44 affected, firefox45 fixed, firefox46 fixed, firefox47 fixed)

Details

Attachments

(5 attachments)

(Assignee)

Description

2 years ago
We should replace the "You must enable DRM to play some audio or video on this page" info bar's "Options" drop-down menu with a "Not Now" button. If we allow the user to "Don't ask me again", then they will get into a state where they don't know why Netflix doesn't work. If this message is nagging the user too much, then they should either enable the Adobe CDM or stop trying to play DRM video with DRM disabled!

https://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/browser.properties#670
Javaun - can you find someone to work on this in Firefox?
Flags: needinfo?(jmoradi)
(Assignee)

Comment 2

2 years ago
Created attachment 8711429 [details] [diff] [review]
part-1-remove-options-button.patch

Part 1: Remove "Don't ask me again" footgun option from the "Enable DRM" info bar notification. To dismiss the EME notification without enabling DRM, the user can just click the bar's [X] button.

We suspect the EME notification bar's "Don't ask me again" menu item (in the bar's Options menu) is a bad UX and can lead the user into a state where they don't know why Netflix doesn't work. If this message is nagging the user too much, then they should either enable the Adobe CDM or stop trying to play DRM video with DRM disabled! :)
Assignee: nobody → cpeterson
Status: NEW → ASSIGNED
Flags: needinfo?(jmoradi)
Attachment #8711429 - Flags: review?(spohl.mozilla.bugs)
(Assignee)

Comment 3

2 years ago
Created attachment 8711430 [details] [diff] [review]
part-2-remove-64bit-message.patch

Part 2: Remove unused EME drmContentCDMNotSupported.64bit.message. Now that we support Adobe's CDM on both 32-bit and 64-bit Firefox, the "video on this page requires DRM software that this 64-bit build does not support" error message is no longer necessary.
Attachment #8711430 - Flags: review?(spohl.mozilla.bugs)
(Assignee)

Comment 4

2 years ago
Created attachment 8711432 [details]
new-notification-screenshot.png

Philipp, here is a screenshot of our new proposed EME notification bar.

We suspect the EME notification bar's "Don't ask me again" menu item can lead the user into a state where they don't know why Netflix doesn't work. If this message is nagging the user too much, then they should either enable the Adobe CDM or stop trying to play DRM video with DRM disabled! :)

With the "Don't ask me again" menu item removed, we no longer need the "Options" drop-down menu either. Do you see any problems with this new design? Or only having the bar's small [X] button to dismiss the EME notification if the user doesn't want to enable DRM?
Attachment #8711432 - Flags: ui-review?(philipp)
(Assignee)

Comment 5

2 years ago
Created attachment 8711433 [details]
current-notification-screenshot.png

For comparison, here is a screenshot of the current EME notification bar with the "Don't ask me again" option.
(Assignee)

Updated

2 years ago
Attachment #8711429 - Attachment description: 1234355_part-1-remove-options-button.patch → part-1-remove-options-button.patch
(Assignee)

Updated

2 years ago
Attachment #8711430 - Attachment description: 1234355_part-2-remove-64bit-message.patch → part-2-remove-64bit-message.patch
Attachment #8711429 - Flags: review?(spohl.mozilla.bugs) → review+
Comment on attachment 8711430 [details] [diff] [review]
part-2-remove-64bit-message.patch

Review of attachment 8711430 [details] [diff] [review]:
-----------------------------------------------------------------

This change should probably have its separate bug, but since this is a rather small change, I'm fine with it here. Just one question (see below), but r+ from me either way.

::: browser/base/content/browser-eme.js
@@ +102,4 @@
>      if (notificationId == "drmContentCDMNotSupported" &&
>          keySystem.startsWith("com.adobe")) {
>        let os = Services.appinfo.OS.toLowerCase();
> +      if (os.startsWith("linux") || os.startsWith("darwin")) {

Can we write this as:
if (!os.startsWith("win")) {
  ...
}
or is there a reason against that?
Attachment #8711430 - Flags: review?(spohl.mozilla.bugs) → review+
(In reply to Stephen A Pohl [:spohl] from comment #6)
> Comment on attachment 8711430 [details] [diff] [review]
> part-2-remove-64bit-message.patch
> 
> Review of attachment 8711430 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> This change should probably have its separate bug

Oh, this is the message in the dropdown, isn't it? Nevermind my comment then. Carry on. :-)
(In reply to Stephen A Pohl [:spohl] from comment #7)
> (In reply to Stephen A Pohl [:spohl] from comment #6)
> > Comment on attachment 8711430 [details] [diff] [review]
> > part-2-remove-64bit-message.patch
> > 
> > Review of attachment 8711430 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > This change should probably have its separate bug
> 
> Oh, this is the message in the dropdown, isn't it? Nevermind my comment
> then. Carry on. :-)

sigh, s/dropdown/info bar notification/
(Assignee)

Comment 9

2 years ago
(In reply to Stephen A Pohl [:spohl] from comment #6)
> Comment on attachment 8711430 [details] [diff] [review]
> ::: browser/base/content/browser-eme.js
> @@ +102,4 @@
> >      if (notificationId == "drmContentCDMNotSupported" &&
> >          keySystem.startsWith("com.adobe")) {
> >        let os = Services.appinfo.OS.toLowerCase();
> > +      if (os.startsWith("linux") || os.startsWith("darwin")) {
> 
> Can we write this as:
> if (!os.startsWith("win")) {
>   ...
> }
> or is there a reason against that?

I just wanted to minimize the code changes, but !win makes sense. I don't know if Firefox on other operating systems (Android or BSD?) might fall through this code path. That would break the existing assumption that !linux implies Mac OS X.
backed out for test failures like https://treeherder.mozilla.org/logviewer.html#?job_id=20466540&repo=mozilla-inbound
Flags: needinfo?(cpeterson)
(Assignee)

Comment 13

2 years ago
These test errors are regressions from bug 1242321:

INFO TEST-UNEXPECTED-FAIL | dom/tests/mochitest/general/test_interfaces.html | If this is failing: DANGER, are you sure you want to expose the new interface MediaKeyError to all webpages as a property on the window (XBL: false)? Do not make a change to this file without a  review from a DOM peer for that specific change!!! (or a JS peer for changes to ecmaGlobals)
Flags: needinfo?(cpeterson)

Comment 15

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/db9f445144e2
https://hg.mozilla.org/mozilla-central/rev/3d625e289ebf
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
(Assignee)

Comment 17

2 years ago
Comment on attachment 8711429 [details] [diff] [review]
part-1-remove-options-button.patch

Approval Request Comment
[Feature/regressing bug #]: 

[User impact if declined]: This patch removes the EME notification bar's "Don't ask me again" menu item because we suspect it can lead the user into a state where they don't know why Netflix doesn't work. If this message is nagging the user too much, then they should either enable the Adobe CDM or stop trying to play DRM video with DRM disabled! :)

[Describe test coverage new/current, TreeHerder]: Tested on Nightly for a couple days.

[Risks and why]: Low risk because this notification bar is only shown in the uncommon case where a user tries to play Netflix after they have disabled EME (unchecked the "Play DRM content" setting). We know this does actually happen. :)

[String/UUID change made/needed]: Some localized strings are removed (e.g. "Don't ask me again"), but no strings are added or modified.
Attachment #8711429 - Flags: approval-mozilla-beta?
Attachment #8711429 - Flags: approval-mozilla-aurora?
Chris, could you write a new patch without the string removals? l10n folks prefer to keep them in an uplift.

Thanks
Flags: needinfo?(cpeterson)
(Assignee)

Updated

2 years ago
Attachment #8711429 - Flags: approval-mozilla-beta?
Attachment #8711429 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

2 years ago
Flags: needinfo?(cpeterson)
Attachment #8711432 - Flags: ui-review?(philipp)
(Assignee)

Comment 19

2 years ago
Created attachment 8714505 [details] [diff] [review]
part-1-remove-options-button_REBASED-FOR-UPLIFT.patch

I rebased this patch (part 1) for uplift and removed the string deletions.

Approval Request Comment
[Feature/regressing bug #]: 

[User impact if declined]: This patch removes the EME notification bar's "Don't ask me again" menu item because we suspect it can lead the user into a state where they don't know why Netflix doesn't work. If this message is nagging the user too much, then they should either enable the Adobe CDM or stop trying to play DRM video with DRM disabled! :)

[Describe test coverage new/current, TreeHerder]: Tested on Nightly for a couple days.

[Risks and why]: Low risk because this notification bar is only shown in the uncommon case where a user tries to play Netflix after they have disabled EME (unchecked the "Play DRM content" setting). We know this does actually happen. :)

[String/UUID change made/needed]: Some localized strings are removed (e.g. "Don't ask me again"), but no strings are added or modified.
Attachment #8714505 - Flags: approval-mozilla-beta?
Attachment #8714505 - Flags: approval-mozilla-aurora?
Comment on attachment 8714505 [details] [diff] [review]
part-1-remove-options-button_REBASED-FOR-UPLIFT.patch

Removes a notification bar, ok in m-c, ok to uplift to aurora and beta.
Attachment #8714505 - Flags: approval-mozilla-beta?
Attachment #8714505 - Flags: approval-mozilla-beta+
Attachment #8714505 - Flags: approval-mozilla-aurora?
Attachment #8714505 - Flags: approval-mozilla-aurora+

Comment 22

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/b7ba1695d494
status-firefox45: affected → fixed

Comment 23

2 years ago
[bugday-20160323]

Status: RESOLVED,FIXED -> VERIFIED

Comments:
STR: 
From given, I can say that rather than checkbox, DRM requires more options for the users if they want to customize their media experience.

Component: 
Name 			Firefox
Version			46.0b9
Build ID		20160322075646
Update Channel          beta
User Agent		Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
OS			Windows 7 SP1 x86_64

Expected Results: 
Customized button for DRM contents.

Actual Results: 
Only Enable now button is there without any other options.
(In reply to Mayur Patil from comment #23)
> Customized button for DRM contents.

We make it possible to disable DRM for those who find it objectionable. Why should it be customisable? Who does it serve?

Comment 25

2 years ago
For the record, I am one of "those people" who tries to play Netflix with DRM content disabled.. the reason I do this is because I prefer to use the Silverlight player which Netflix still fully supports as it has a hidden menu (alt+shift+Lclick > stream manager) that allows me to force a specific stream quality setting which the DRM version of the player does not have.

I would very much like to see the "Do not ask again" option re-instated, even if it is only available after changing an about:config setting or something, so that normal uses won't get into the "don't know why Netflix doesn't work" state, but people who have Silverlight or otherwise know what they are doing have the option to bypass that admittedly otherwise handy safety feature!
There is an option in Netflix's user interface to opt for higher quality. Go: Your Account > My Profile > Playback Settings > Data Usage per Screen.

You can also select a specific resolution in the Netflix player by pressing CTRL+ALT+SHIFT+S.

I find the Silverlight player drops frames, and that the HTML5 player is thus a vastly superior experience.
You need to log in before you can comment on or make changes to this bug.