Websites pinned as a page are missing the preview in their icons

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Mihai Barbat, Assigned: albertopq)

Tracking

({foxfood, regression})

unspecified
2.6 S6 - 1/29
ARM
Gonk (Firefox OS)
foxfood, regression

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
I am using a Flame phone running OTA 20151222030233. When I want to see my sites pinned as a page, their icons are missing the preview of the page.

Please take a look at the screenshot I took to see the problem: http://i.imgur.com/Ymaxclv.png
(Reporter)

Updated

2 years ago
Keywords: foxfood
Can QA reproduce?
Keywords: qawanted
Whiteboard: [systemsfe]
I see this on Aries using:

Build ID               20151229105558
Gaia Revision          63c3a57ad9935b9c61057a29ee27a1c6ed6a9e23
Gaia Date              2015-12-29 06:59:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9ddf0da90fb3bc1ae29966dc596013fc54a44bd2
Gecko Version          46.0a1
Keywords: qawanted → regression, regressionwindow-wanted
Created attachment 8702584 [details]
Screenshot of pinned site with preview, on an earlier build

This is a screenshot of the NY Times site with the preview. In the current builds, the preview is missing on that same site and only the "T" icon is present.

Comment 4

2 years ago
I have the same problem on my Flame:

Serial: f0434001 (State: device)
Build ID               20151229030208
Gaia Revision          63c3a57ad9935b9c61057a29ee27a1c6ed6a9e23
Gaia Date              2015-12-29 06:59:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9ddf0da90fb3bc1ae29966dc596013fc54a44bd2
Gecko Version          46.0a1
QA Whiteboard: [QAnalyst-Triage+][severe]
Can we get a regression window?
blocking-b2g: --- → 2.6+
Bug 1222074 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.6
BuildID: 20151221034634
Gaia: 56c9fd0d6cf5d049a596d629199416041644777a
Gecko: 26790e1553e29be911fb99f9d9ce51bcf9fb0b53
Version: 46.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

First Broken 
Environmental Variables:
Device: Flame 2.6
BuildID: 20151221040642
Gaia: 3f04cb73f41a61f932b8e87474c29d214f6d89a2
Gecko: 1533a281cf7655f7dfc539a59541af8d878436e8
Version: 46.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 56c9fd0d6cf5d049a596d629199416041644777a
Gecko: 1533a281cf7655f7dfc539a59541af8d878436e8

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 3f04cb73f41a61f932b8e87474c29d214f6d89a2
Gecko: 26790e1553e29be911fb99f9d9ce51bcf9fb0b53

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/56c9fd0d6cf5d049a596d629199416041644777a...3f04cb73f41a61f932b8e87474c29d214f6d89a2
Blocks: 1222074
QA Whiteboard: [QAnalyst-Triage+][severe] → [QAnalyst-Triage?][severe]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Alberto can you please take a look at this issue?
Flags: needinfo?(apastor)
QA Whiteboard: [QAnalyst-Triage?][severe] → [QAnalyst-Triage+][severe]
Flags: needinfo?(ktucker)
(Assignee)

Updated

2 years ago
Assignee: nobody → apastor
Flags: needinfo?(apastor)
Created attachment 8708970 [details] [review]
[gaia] albertopq:1234568-pin-background > mozilla-b2g:master
(Assignee)

Comment 9

2 years ago
Comment on attachment 8708970 [details] [review]
[gaia] albertopq:1234568-pin-background > mozilla-b2g:master

We store the screenshot in place.screenshot, and not in place.meta.screenshot as we were expecting. Guillaume, could you take a look? Thanks!
Attachment #8708970 - Flags: review?(gmarty)
Comment on attachment 8708970 [details] [review]
[gaia] albertopq:1234568-pin-background > mozilla-b2g:master

It looks good to me. Thanks Alberto for fixing that.
Attachment #8708970 - Flags: review?(gmarty) → review+
(Assignee)

Comment 11

2 years ago
master: https://github.com/mozilla-b2g/gaia/commit/2242b76f4c146e3cae2a7af1771a5dbb6276d133
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

2 years ago
Duplicate of this bug: 1235119

Updated

2 years ago
QA Whiteboard: [QAnalyst-Triage+][severe] → [QAnalyst-Triage+][severe][COM=Pin the Web]
(Reporter)

Comment 13

2 years ago
Awesome. I just got the OTA 20160122030206 for the Flame and I can confirm this issue is fixed!

Thanks! :)
This issue is Verified Fixed.
Result: Pinned icons now display the proper background associated with their corresponding website.

Environmental Variables:
Device: Aries kk 2.6
BuildID: 20160122110550
Gaia: 92ed2a5ffd685bc8797bb15a84307cafe6d04f64
Gecko: 7104d650a97d895cbbc64d53462bf86a04658abe
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Environmental Variables:
Device: Flame Kk 2.6 Full Flash (512mb)
BuildID: 20160122030206
Gaia: 92ed2a5ffd685bc8797bb15a84307cafe6d04f64
Gecko: 4685564e5d8f1fcb8045ab6591a64ecad0e6fac8
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][severe][COM=Pin the Web] → [QAnalyst-Triage?][severe][COM=Pin the Web]
status-b2g-master: --- → verified
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?][severe][COM=Pin the Web] → [QAnalyst-Triage+][severe][COM=Pin the Web]
Flags: needinfo?(jmercado)
Target Milestone: --- → 2.6 S6 - 1/29
You need to log in before you can comment on or make changes to this bug.