Issue on Image when is inserted from an URL

RESOLVED INVALID

Status

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: ocispposta, Unassigned)

Tracking

38 Branch
All
Windows 10

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151216175450

Steps to reproduce:

Created new email from my personal domain email addres configured in Thunderbird as IMAP to use SSL


Actual results:

After i Insert Image with URL and continued to write the message, Thunderbird try to save and replace the Image URL with a broken URL
http://postimg.org/image/ruvd74eyl/
http://postimg.org/image/5orxjl3xv/
who not work so image are not more visible and I can't write an email in this way if after some minutes Thunderbird remove my Image with a URL who not work so Image are no more showed also if I send that mail.

This is very old problem not yet resolved with Thunderbird.


Expected results:

The URL of the image as is not an uploaded image should stay the same so image are visible.

URL of that image in the web should not be replaced as is not attached to the email.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → All
(Reporter)

Comment 1

3 years ago
Seems the issue is only when the automatic save is done.
If I use save draft the issue is not present.

Just create a email, insert the image and write some text than wait 10 minutes or more when an automatic draft is saved the image is transformed in broken image.

Not only with my personal domain name but tested now also with Gmail address and the issue is the same.
(Reporter)

Updated

3 years ago
Severity: normal → major
(Reporter)

Comment 2

3 years ago
This issue should be resolved in Thunderbird and not loosed here :)
(Reporter)

Comment 3

3 years ago
Can someone take care of this issue? Or tell me why still no update?
Can I send other detail? There are something wrong?

The last Thunderbird continue to have this issue... cause me difficult to compose email.
Thanks.
(Reporter)

Comment 4

3 years ago
How reproduce:

1. create new email
2. Insert an image from URL example take the URL of an image in Facebook and press insert image than put the image URL.
3. write email text.
4. wait the automatic save

5. image will be missed. The URL of the image is replaced by a IMAP address who are not valid for image.
See the attachment image
(Reporter)

Comment 5

3 years ago
Created attachment 8732802 [details]
Screen SHot of the Issue

Screen Shot of the Issue
(Reporter)

Comment 6

3 years ago
No one take care about that?
(Reporter)

Updated

3 years ago
Priority: -- → P5
(Reporter)

Updated

3 years ago
Priority: P5 → P1

Updated

3 years ago
Duplicate of this bug: 1260150

Comment 8

3 years ago
Note that this is a bug-reporting system and not a forum or real-time chat, thus replies may not be immediate. Quick answer: By default, images are attached to a message. You can prevent that by double-clicking on the image after inserting it and unchecking the "Attach to message" box. This only works until the message is sent or saved as draft. If you have "Save automatically every [__] minutes" set, this may happen before you get a chance to switch that box.
Component: Untriaged → Message Compose Window
Priority: P1 → --

Comment 9

3 years ago
I inserted this image http://www.jorgk.com/images/arflag.png into a message (got attached by default) and saved the message in my IMAP drafts folder. After opening the draft again, the image location has changed to:
imap://<e-mail-address>@imap.googlemail.com:993/fetch%3EUID%3E/%5BGmail%5D/Drafts%3E231?part=1.2&filename=arflag.png

This is what can be seen it you attachment 8732802 [details].

However, the image did not disappear for me. What am I missing?
Severity: major → normal
(Reporter)

Comment 10

3 years ago
Hi Jorg,
the image should be insert as URL so you take the URL of the image: http://www.jorgk.com/images/arflag.png

After done that the image is showed in the email message. Now just wait some minutes until a automated save save the draft. You don't have to save manually but wait the auto save. I insert the image and write some text (.)

Now have to wait ... when there are autosave image is no working any more.
mmmmmm but I AM trying to reproduce today an I AM unable. Uff...

I will test in this hours, IF I AM unable to reproduce I will close.... Don't know why now I AM unable to reproduce.
(Reporter)

Comment 11

3 years ago
Can't reproduce again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID

Comment 12

3 years ago
We're happy to look into any issue that can be reproduced.

If the problem happens again later and you can reproduce it, please leave a comment here.

Note that storing drafts on the Gmail server via IMAP can at times cause problems, and I can imagine that an embedded/attached image can disappear in the process.

I always recommend to store drafts in local folders:
Tools > Account Settings, your account, Copies & Folders, Keep message drafts in ...
You can select a local folder there.
(Reporter)

Comment 13

3 years ago
Thank you. I was not able to reproduce only with Gmail but also with my personal domain.
Many time I have issue on composing email with picture in different days and time.

Now I really can't understand why I AM unable to reproduce again.

Thanks.
Also here in bugzilla I cannot understand how to find again a BUG with status resolved Invalid. It is not present in Dashboard or in any list, can reach only IF I have the link in the email. So all time IF the BUG is present again I cannot find old BUG I need open new one.
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1166168
You need to log in before you can comment on or make changes to this bug.