Closed Bug 1235128 Opened 6 years ago Closed 6 years ago

[TV][2.5] System banner supports icon and title

Categories

(Firefox OS Graveyard :: Gaia::TV::System, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

VERIFIED FIXED
2.6 S4 - 1/1
feature-b2g 2.5+
Tracking Status
b2g-v2.5 --- verified
b2g-master --- verified

People

(Reporter: rickychien, Assigned: rickychien)

References

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick])

Attachments

(5 files, 1 obsolete file)

According to Visual Spec 3.3, system banner has to show up with a left icon as well as a title.
feature-b2g: --- → 2.5+
Whiteboard: [ft:conndevices][partner-cherry-pick]
Priority: -- → P2
Target Milestone: --- → 2.6 S4 - 1/1
Comment on attachment 8703122 [details] [review]
[gaia] rickychien:extendSystemBanner > mozilla-b2g:master

Hey Luke, happy new year!
Attachment #8703122 - Flags: review?(lchang)
Attached file PR for smart-components (obsolete) —
Attachment #8703244 - Attachment is obsolete: true
Comment on attachment 8703122 [details] [review]
[gaia] rickychien:extendSystemBanner > mozilla-b2g:master

Nice work! Don't forget to sync your modification with your another pull request of "smart-banner".

Thanks.
Attachment #8703122 - Flags: review?(lchang) → review+
Landed in gaia master:

https://github.com/mozilla-b2g/gaia/commit/0d79de590f319619cd028a813f08f267e596d4a0

Landed in smart-components:

https://github.com/smart-components/smart-banner/commit/77486577258d1258e32a6818e7db84f7f9055c15
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8703122 [details] [review]
[gaia] rickychien:extendSystemBanner > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): feature of bug 1204762
[User impact] if declined: feature request by partner
[Testing completed]: manual verified on local
[Risk to taking this patch] (and alternatives if risky): medium
[String changes made]:
added-to-apps
deleted-from-apps
press-option-hint
Attachment #8703122 - Flags: approval-gaia-v2.5?
Comment on attachment 8703122 [details] [review]
[gaia] rickychien:extendSystemBanner > mozilla-b2g:master

Approved for TV 2.5
Attachment #8703122 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
See Also: → 1241422
You need to log in before you can comment on or make changes to this bug.