Closed Bug 12355 Opened 20 years ago Closed 20 years ago

Calls to getenv()

Categories

(Core :: Layout, defect, P2, major)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: troy, Assigned: buster)

References

()

Details

(Whiteboard: [Perf])

Kipp, in looking at Quantify runs of an optimized build with symbols, we're
spending 15% of the total time in calls to getenv() from
nsInlineFrame::ReflowInlineFrames().

The code seems somewhat questionable, but the actual performance problem seems
like an oversight. It looks like "firstTime" isn't getting set to 0 and hence we
call this over and over and over
*** Bug 11702 has been marked as a duplicate of this bug. ***
Blocks: 11702
Summary: [PERF] Calls to getenv() → Calls to getenv()
Whiteboard: [Perf]
Severity: normal → major
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: M10
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I fixed this dumb bug; the code is only present for me (as it was supposed to
be) and the getenv call will now be made once instead of every time (DOH).
Status: RESOLVED → VERIFIED
Based on Kipp's comment's, marking as verified fixed in the Sept 2nd build.
Duplicate of this bug: 1497074
You need to log in before you can comment on or make changes to this bug.