Closed Bug 11702 Opened 21 years ago Closed 21 years ago

[PERF] Very slow layout

Categories

(Core :: Layout, defect, P3)

All
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: mloiselle, Assigned: troy)

References

()

Details

This page take over 1 minute to display.  That's on a Pentium III 450.  Very
slow with Naviga
This page is also very slow with Navigator 4.x on all platforms.
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Summary: Very slow layout → [PERF] Very slow layout
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
*** This bug has been marked as a duplicate of 12355 ***
Status: REOPENED → ASSIGNED
Depends on: 12355
I accidentally marked this as a DUP. I meant to add a dependency
Depends on: 12362
Depends on: 12369
In addition to the three other bugs I filed, I made a change to
ReparentFrameView() that helps as well. We were spending too much time when
pushing/pulling frames checking to see whether we needed to reparent views of
the frames
Target Milestone: M11
Target Milestone: M11 → M13
Depends on: 10736
The big problems seems to be bug #10736. However, this past weekend I optimized
the text frame code so that for resize reflows it tries to avoid re-measuring
the text. This helps resizing the window, and it also helps tables (which this
page uses)
*** Bug 16622 has been marked as a duplicate of this bug. ***
Blocks: 17265
*** Bug 17692 has been marked as a duplicate of this bug. ***
*** Bug 17410 has been marked as a duplicate of this bug. ***
*** Bug 19299 has been marked as a duplicate of this bug. ***
*** Bug 19004 has been marked as a duplicate of this bug. ***
*** Bug 17692 has been marked as a duplicate of this bug. ***
Status: ASSIGNED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
I think it loads in a reasonable amount of time now. Lots of work has been done
to get to this point

Marking FIXED
Page loads fine for me under the Feb 01 build. Marking verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.