Closed Bug 1235734 Opened 4 years ago Closed 4 years ago

Emulator test jobs on taskCluster are skipping log uploads

Categories

(Testing :: General, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1248318

People

(Reporter: edgar, Assigned: edgar)

References

Details

Attachments

(2 obsolete files)

It looks like all emulator test jobs on taskcluster lose logs, for example [1],

13:40:43     INFO - Running post-run listener: _upload_blobber_files
13:40:43  WARNING - Blob upload gear skipped. Missing cmdline options.
13:40:43     INFO - Copying logs to upload dir...
13:40:43     INFO - mkdir: /home/worker/build/upload/logs
========= Finished Running tests (results: 0, elapsed: 1357 secs) (at 2015-12-23 13:40:43.222451) ========= [taskcluster] === Task Finished ===
[taskcluster] Artifact "public/logs/" not found at "/home/worker/workspace/build/upload/logs/"
[taskcluster] Artifact "public/test_info/" not found at "/home/worker/workspace/build/blobber_upload_dir/"

[1] https://treeherder.mozilla.org/logviewer.html#?job_id=14847469&repo=try#L850-L856
See Also: → 1221553
Looks like the MOZ_UPLOAD_DIR doesn't match the artifacts path defined in test.yml

INFO - 'MOZ_UPLOAD_DIR': '/home/worker/build/blobber_upload_dir'
...
[taskcluster] === Task Finished ===
[taskcluster] Artifact "public/logs/" not found at "/home/worker/workspace/build/upload/logs/"
[taskcluster] Artifact "public/test_info/" not found at "/home/worker/workspace/build/blobber_upload_dir/"
Blocks: 1222944
Attached patch WIP, Patch, v1 (obsolete) — Splinter Review
Just a workaround patch to make it work. It may not a good way to solve this problem.
Depends on: 1238469
Priority: -- → P3
Talked with Edgar, this is a regression recently and we need to fix this to have device log back. Set priority to P1.
Priority: P3 → P1
Hi Edgar, I think this is in your plan so I am assigning to you first! Fell free to let me know if you have other concerns.
Assignee: nobody → echen
Depends on: 1245398
Attachment #8703074 - Attachment is obsolete: true
Depends on: 1248318
After bug 1248318 is landed, I can see device logs shown in task inspector again,

https://tools.taskcluster.net/task-inspector/#fQWCkF7JQBSJ-LNXd9AeLg/0

So mark as a duplicate of bug 1248318.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1248318
Attachment #8716735 - Attachment is obsolete: true
That's great!
You need to log in before you can comment on or make changes to this bug.