pushManager.subscribe does not resolve or reject the promise on closing the permission prompt

RESOLVED DUPLICATE of bug 1241749

Status

()

Core
DOM: Push Notifications
RESOLVED DUPLICATE of bug 1241749
2 years ago
2 years ago

People

(Reporter: matt, Unassigned)

Tracking

({testcase})

46 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160103030302

Steps to reproduce:

I've been looking at ways to simplify building UI for push and one of the things I noticed was that calling subscribe and simply closing the permission dialog results in the subscribe() promise not resolving.

Steps to reproduce:

1. Go to: https://simple-push-demo.appspot.com/
2. *Double check current permission state is to always ask
3. Click the toggle switch
4. Close the permission dialog (i.e. click the cross in the top right of the permission pop up)


Actual results:

The UI stays disabled.


Expected results:

The UI should either switch back to the off, enabled state, or switch on to the enabled state.

Comment 1

2 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
20160103030302
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Component: Untriaged → DOM: Push Notifications
Ever confirmed: true
Keywords: testcase
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Thank you for triaging this!

I think this is "working as intended" (see bug 675533 for the same discussion around geolocation prompts). A lot of comments on that bug express confusion and frustration around the current behavior, so maybe it's time to revisit.

FWIW, if you dismiss the dialog without granting or rejecting the permission, the icon remains in the address bar, and you can recall the dialog by clicking on the icon. In practice, I'm not sure how many folks do that, or are even aware of it.
See Also: → bug 675533
(Reporter)

Comment 3

2 years ago
I hadn't noticed the UI in the url bar.

I suppose this is a FF feature.

My assumption (perhaps wrongly) was that a permission status would be prompt, granted or denied after a User Agent had hidden it's permission. This introduces a kind of limbo state of a "pending-response" which could lead to some odd UX within websites, but I can see how this could be desirable from a UA and user.

Thanks for the info.
Continuing the discussion in bug 1241749.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1241749
Duplicate of this bug: 1242614
You need to log in before you can comment on or make changes to this bug.