subscribe() should reject with PermissionDeniedError if the user doesn't grant the permission

RESOLVED DUPLICATE of bug 1236352

Status

()

defect
RESOLVED DUPLICATE of bug 1236352
3 years ago
3 years ago

People

(Reporter: marco, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

3 years ago
Currently, the promise is never resolved if the user dismisses the prompt.
Reporter

Updated

3 years ago
See Also: → 1241749
Marco, isn't that the point?  The answer of "did the user approve this" never got resolved.

if you set a timeout in PostionOptions -- that should probably do what you want.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Reporter

Comment 2

3 years ago
Looks like there's a long discussion in bug 675533 and another started in bug 1241749, since probably most people when they dismiss the prompt actually mean to decline the permission.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1236352
You need to log in before you can comment on or make changes to this bug.