Closed Bug 1236533 Opened 5 years ago Closed 5 years ago

Url opened in a new tab is lost if I cancel page loading

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1110297
Tracking Status
firefox46 --- affected

People

(Reporter: arni2033, Unassigned)

References

()

Details

Attachments

(1 file)

>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20160103030302
STR:
0. Disable cache: Open about:preferences#advanced -> "Network" -> "Limit cache to 0 MB of space"
1. Open the following "data:" url in a new tab (really, I only need a source to drag a link)
>   data:text/html,<textarea cols="70">https://bugzilla.mozilla.org/show_bug.cgi?id=1236528
2. Select the url in <textarea>, hold Shift, drag-n-drop the url at the right side of selected tab
   [it will start loading in the foreground]
3. While the active tab (opened in Step 2) still shows title "Connecting..." (gray spinner),
   hold Escape key to cancel loading
4. Right-click the tab, click "Reload Tab"

Result:       Title displays "New tab". Urlbar is empty. Page is actually about:blank
Expectations: After Step 4 the url from Step 2 should start _loading_again_
See Also: → 1236528
Component: Untriaged → Document Navigation
Product: Firefox → Core
No, this is a UI issue.  The UI is what forgets the URI; the core code never got as far as having it loaded, so doesn't have it at all.
Component: Document Navigation → Tabbed Browser
Product: Core → Firefox
See Also: → 798249
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1110297
See Also: 1236528
You need to log in before you can comment on or make changes to this bug.