Cannot relaunch browser since no cleanup of file in use

VERIFIED DUPLICATE of bug 136497

Status

Core Graveyard
Installer: XPInstall Engine
--
major
VERIFIED DUPLICATE of bug 136497
16 years ago
2 years ago

People

(Reporter: Jimmy Lee, Assigned: dprice (gone))

Tracking

({pp})

Trunk
mozilla1.0
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt1])

(Reporter)

Description

16 years ago
Build: 2002-02-04-17-trunk(MAC OS X) 10.1

1. From http://jimbob/trigger3.html, click on Acceptance drop-down and choose 
   a_addfiledel
2. Click Trigger case button
3. Click Install button from Software Installation dialog
4. From Netscape.app/Contents/MacOS/addfiledelete, open smrtupdt.txt with any
   any editor such as vi
5. While this file is in use, repeat above steps 1-3
6. Exit the editor from step 4
7. Exit browser
8. Relaunch browser

RESULT:
smrtupdt.old becomes the name of the first file that was installed.  The second
file installed is named smrtupdt.txt as expected.  Dialog appears "A previous
install did not complete correctly.  Finish install."  Relaunching will always
repeat this dialog.  "XPICleanup Data" remains present from Essential Files folder.

EXPECTED RESULT:
"XPICleanup Data" is not present from Essential Files folder.  Browser launches
without dialog about previous install not completed.  smrtupdt.txt is only file
that remains from Netscape.app/Contents/MacOS/addfiledelete.
(Reporter)

Comment 1

16 years ago
Nominating for beta.  We need to be able to replace files in use because it is a
common activity such as upgrading a plugin.  I did forget to mention that this
problem is similar (unable to relaunch browser) when replacing binary files.
Keywords: nsbeta1, pp

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9

Comment 2

16 years ago
Resetting milestone, only nsbeta1+ bugs can have a milestone on them, these are
niminated, but not yet plussed.
Target Milestone: mozilla0.9.9 → ---

Comment 3

16 years ago
plussing, possibly as bug for dprice
Keywords: nsbeta1 → nsbeta1+
Target Milestone: --- → mozilla1.0
This is possibly the same as bug 123649 -- if nsIProcess were the culprit in bug
123649 then I'd expect the launch of the cleanup utility to fail. There could be
other reasons launching the cleanup utility would fail, though, such as path or
filename problems or even not having the utility present at all.
Assignee: dveditz → dprice
Status: ASSIGNED → NEW

Comment 5

16 years ago
adt1 per triage
Whiteboard: [adt1] per triage

Comment 6

16 years ago
Adding greggl.
(Assignee)

Comment 7

16 years ago
I looks like XPICleanup isn't being build on OSX

From MozillaBuildList.pm line 1957
if (!$main::options{carbon}) {

BuildOneProject(":mozilla:xpinstall:cleanup:macbuild:XPICleanup.xml",          
                   "XPICleanup$D", 1, $main::ALIAS_SYM_FILES, 0);

InstallFromManifest(":mozilla:xpinstall:cleanup:MANIFEST_CMESSAGE",        
"$resource_dir");

}

CVS Blame comments indicate this was done to "Fix Fizilla build"
(Assignee)

Updated

16 years ago
Depends on: 136497
Whiteboard: [adt1] per triage → [adt1]
(Assignee)

Updated

16 years ago
No longer depends on: 136497
Depends on: 136497
(Assignee)

Comment 8

16 years ago
I tested this bug with the fix for 136497.  That fix resolves all of the issues
with this bug.  

136497 has an accurate assessment of the problem, the fix, its r= and its sr=

Is it okay for me to move the keywords and status whiteboard over to the other
bug and mark this one as a duplicate?  That seems like the right thing to do.

*** This bug has been marked as a duplicate of 136497 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 10

16 years ago
Bug 136497 has been verified.  Marking this one Verified.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.