TB hangs for certain RSS Feeds

RESOLVED WORKSFORME

Status

MailNews Core
Feed Reader
--
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Unpatented, Unassigned)

Tracking

(Blocks: 1 bug, {hang, reproducible})

x86_64
Windows 7
hang, reproducible

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:24.7) Gecko/20140907 PaleMoon/24.7.2
Build ID: 20140907202139

Steps to reproduce:

I have an RSS feed subscription setup for this feed: http://slickdeals.net/rss.php

When I open these RSS articles (by a doubleclick in the RSS listing, which opens into a new mail window to show the HTML - I don't use preview pane) and interact with them a bit, by clicking links, scrolling, etc, most times, on closing the feed entry window by the X in the corner, the main Thunderbird window, and any other message windows also open, close as well. The program is still running, but all GUI windows are closed and cannot be gotten back. I have to kill the TB process and restart it in order to recover from the crash. This crash doesn't trigger the Crash Reporter tool. I also tested it in Safe Mode, and the crash still happens. I have another RSS feed or two where this crash rarely happens, but this site is the most reliable and frequent crash. I also notice that the option "Show the Article Summary instead of the Web Page" doesn't seem to work, as it shows the webpage(HTML) regardless of the selected option.

This seemed to start around the time that Thunderbird 38 came out. I didn't have this crash issue before then.


Actual results:

Frequently, the main Thunderbird window also closes when the message window is closed. It can't be recovered, as far as I can tell, and the process must be killed, and TB restarted.


Expected results:

The message window should close, without taking the rest of the application GUI with it.
(Reporter)

Updated

2 years ago
Severity: normal → critical
Keywords: crash, reproducible
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

2 years ago
I did try this on another Windows 7 64 bit computer with the same results. So I'm pretty sure it's quite reproducible. Still, I want to get confirmation on its reproducibility so I know whether I need to get setup to try to get a crash dump.

Updated

2 years ago
Blocks: 482756
Component: Untriaged → Feed Reader
Product: Thunderbird → MailNews Core

Comment 2

2 years ago
This doesn't happen on linux, maybe someone can confirm on win.  In any event, it is perhaps a result of script running in a web page (as opposed to a noscript summary) loaded in a standalone message window and subsequent interactions.  Meaning it has nothing to do with the feed reader code.

(In reply to Unpatented from comment #0)
> reliable and frequent crash. I also notice that the option "Show the Article
> Summary instead of the Web Page" doesn't seem to work, as it shows the
> webpage(HTML) regardless of the selected option.

Not quite. There are different actions and options for a message 'select' vs 'open'.  See the guide for more: https://support.mozilla.org/en-US/kb/how-subscribe-news-feeds-and-blogs

Comment 3

2 years ago
Unpatented,
Can you reproduce this with version 45?
Flags: needinfo?(court)
(Reporter)

Comment 4

2 years ago
I've updated to TB 45.0 and have been using it for a couple weeks.

It seems like the crash behavior that I described initially is no longer happening with TB 45.0. I haven't had TB crash so far when closing out open feed windows. 

However, there is still a crash issue similar to this, as several times now I've had TB crash when simply clicking on HTML links on the Slickdeal pages loaded by the RSS feedreader. It's kinda rare, seemingly more rare than the previous crashing behavior, but it's happened a few times now in the couple weeks since I updated.
Flags: needinfo?(court)

Comment 5

2 years ago
(In reply to Unpatented from comment #4)
> 
> It seems like the crash behavior that I described initially is no longer
> happening with TB 45.0. I haven't had TB crash so far when closing out open
> feed windows. 

Thanks for the update

> However, there is still a crash issue similar to this, as several times now
> I've had TB crash when simply clicking on HTML links on the Slickdeal pages
> loaded by the RSS feedreader. It's kinda rare, seemingly more rare than the
> previous crashing behavior, but it's happened a few times now in the couple
> weeks since I updated.

Crash ID?
https://support.mozilla.org/en-US/kb/mozilla-crash-reporter-tb?redirectlocale=en-US&redirectslug=mozilla-crash-reporter#w_viewing-crash-reports
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

2 years ago
The clicking-hyperlinks crash is the same as the closing-window crash, where all TB windows suddenly close and the GUI cannot be restored. This doesn't trigger the Mozilla crash reporter. The TB process has to be killed manually in order to restart and continue. 

I'll try to get setup for getting a stacktrace manually.

Updated

2 years ago
Keywords: crash → hang
Summary: TB GUI Crash Issue for certain RSS Feeds → TB hangs for certain RSS Feeds
You need to log in before you can comment on or make changes to this bug.