[TV][2.5] Preview window back key also trigger on parent app window

RESOLVED FIXED

Status

Firefox OS
Gaia::TV::System
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rickychien, Assigned: rickychien)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick][partner-blocker])

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
document.activeElement cannot focus immediately when browsing slow loading web page (ex: expedia.com) which causes parent app window will also back to previous page.
Created attachment 8705166 [details] [review]
[gaia] rickychien:fix-back-focus > mozilla-b2g:master
(Assignee)

Comment 2

2 years ago
Comment on attachment 8705166 [details] [review]
[gaia] rickychien:fix-back-focus > mozilla-b2g:master

I noticed that we forgot to set parentWindow.frontWindow = previewWindow; after preview window being created and also fix bug for focusManager.

Here is a small patch for addressing this issue.
Attachment #8705166 - Flags: review?(lchang)
(Assignee)

Comment 3

2 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?

Updated

2 years ago
blocking-b2g: 2.5? → 2.5+

Updated

2 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected

Updated

2 years ago
Whiteboard: [ft:conndevices][partner-cherry-pick][partner-blocker]
(Assignee)

Updated

2 years ago
Summary: [TV] Preview window back key also trigger on parent app window → [TV][2.5] Preview window back key also trigger on parent app window

Comment 4

2 years ago
Comment on attachment 8705166 [details] [review]
[gaia] rickychien:fix-back-focus > mozilla-b2g:master

Good job! Thanks.
Attachment #8705166 - Flags: review?(lchang) → review+
(Assignee)

Comment 5

2 years ago
Thank you Luke.

Landed in master:

https://github.com/mozilla-b2g/gaia/commit/514132d2e74218d607963ae1fe4a4e0ded392f22
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

2 years ago
Comment on attachment 8705166 [details] [review]
[gaia] rickychien:fix-back-focus > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1225081
[User impact] if declined: Unexpected UI behaviors when back key is triggered.
[Testing completed]: manual tested on local
[Risk to taking this patch] (and alternatives if risky): n/a
[String changes made]: n/a
Attachment #8705166 - Flags: approval-gaia-v2.5?

Comment 7

2 years ago
Comment on attachment 8705166 [details] [review]
[gaia] rickychien:fix-back-focus > mozilla-b2g:master

Approve for TV 2.5
Attachment #8705166 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
for 2.5 https://github.com/mozilla-b2g/gaia/commit/d0d4b86a631027b4eb8d3a28c25b930dcb103bc2
status-b2g-v2.5: affected → fixed
status-b2g-master: affected → fixed
You need to log in before you can comment on or make changes to this bug.