Closed Bug 1225081 Opened 6 years ago Closed 6 years ago

[TV][2.5] Open, close and navigate marketplace hosted/packaged app by preview window

Categories

(Firefox OS Graveyard :: Gaia::TV, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: rickychien, Assigned: lchang)

References

Details

(Whiteboard: [ft:conndevices])

Attachments

(4 files)

The hosted/packaged webapps are able to be opened directly when user press "ok" and show up a preview window without any install confirmation.

We allow user to navigate webapp content forward and backward (use "back") until reach landing page.

The user presses the “back” button from the landing page to close the app.
Assignee: nobody → rchien
Blocks: 1211400
Status: NEW → ASSIGNED
Priority: -- → P1
Comment on attachment 8690761 [details] [review]
[gaia] rickychien:bug-1225081 > mozilla-b2g:master

Hi Luke, marketplace preview behavior is ready for review!

At present, marketplaceURLPattern is set to 'marketplace' since new marketplace domain doesn't determine yet.

Please take a look and review it kindly. thanks!
Attachment #8690761 - Flags: review?(lchang)
Comment on attachment 8690761 [details] [review]
[gaia] rickychien:bug-1225081 > mozilla-b2g:master

Hi Ricky,

I've finished my first round review. Please take a look at my comments and set the review flag back after they are addressed. Thanks.
Attachment #8690761 - Flags: review?(lchang)
Comment on attachment 8690761 [details] [review]
[gaia] rickychien:bug-1225081 > mozilla-b2g:master

I've updated my patch, all of your suggestions are fixed. please see it again. thx!
Attachment #8690761 - Flags: review?(lchang)
Comment on attachment 8690761 [details] [review]
[gaia] rickychien:bug-1225081 > mozilla-b2g:master

Looks good now. Thanks a lot.
Attachment #8690761 - Flags: review?(lchang) → review+
Comment on attachment 8690761 [details] [review]
[gaia] rickychien:bug-1225081 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1211400
[User impact] if declined: none
[Testing completed]: manual test complete
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8690761 - Flags: approval-gaia-v2.5?
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: --- → 2.5+
Whiteboard: [ft:conndevices]
Comment on attachment 8690761 [details] [review]
[gaia] rickychien:bug-1225081 > mozilla-b2g:master

Approve as part of TV 2.5 marketplace
Attachment #8690761 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Flags: needinfo?(rchien)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Since Ricky won't be in the office until next Tuesday, I'm taking over this bug.
Assignee: rchien → lchang
Flags: needinfo?(rchien)
Comment on attachment 8692388 [details] [review]
[gaia] luke-chang:1225081_marketplace_preview_app > mozilla-b2g:master

Hi Evelyn,

Would you mind taking a look at this updated patch? It's basically based on Ricky's one. What I've done is as follows:

- simplified the logic
- added the L10N support
- reverted the changes introduced in InteractiveNotifications and applied another patch to fix its focusing issue

Thanks.
Attachment #8692388 - Flags: review?(ehung)
Comment on attachment 8692388 [details] [review]
[gaia] luke-chang:1225081_marketplace_preview_app > mozilla-b2g:master

See my comments on Github. Thanks.
Attachment #8692388 - Flags: review?(ehung)
Comment on attachment 8692388 [details] [review]
[gaia] luke-chang:1225081_marketplace_preview_app > mozilla-b2g:master

Comments are all addressed. Please take a look. Thanks a lot.
Attachment #8692388 - Flags: review?(ehung)
Comment on attachment 8692388 [details] [review]
[gaia] luke-chang:1225081_marketplace_preview_app > mozilla-b2g:master

Looks good to me! thank you~
Attachment #8692388 - Flags: review?(ehung) → review+
Hi Maria,

According to UX Spec (Pic.2, Page.21), the hint "Press OPTION to add to Apps" is displayed in two lines. However, the current notification element treats these two lines as two L10N IDs. That means we need to define these two lines as below:

    preview-app-hint-title=Press OPTION to
    preview-app-hint-text=Add to Apps

It may be hard to localize the strings.

I would suggest merging them into single line but the current implementation doesn't support a single-line notification. Therefore, I added a title "Tips" on it (please refer to the attachment). What do you think? Thanks.
Flags: needinfo?(msandberg)
Hi Maria,

I just found that the system banner is fixed in bug 1220567 so we can utilize it to show a single-line message as the attachment. Is it better than the notification?
Luke, I guess Maria is in vocation, so let's use system banner first. In UX review phase, she will file bugs if she disagrees.
Flags: needinfo?(lchang)
Ok, I'll land the patch with the system banner once tests are all passed.
Flags: needinfo?(lchang)
Comment on attachment 8692388 [details] [review]
[gaia] luke-chang:1225081_marketplace_preview_app > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1211400
[User impact] if declined: feature isn't complete.
[Testing completed]: Yes.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: Yes.
Attachment #8692388 - Flags: approval-gaia-v2.5?
Attachment #8690761 - Flags: approval-gaia-v2.5+
Comment on attachment 8692388 [details] [review]
[gaia] luke-chang:1225081_marketplace_preview_app > mozilla-b2g:master

Approve for TV 2.5 marketplace
Attachment #8692388 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Hi Luke, sorry for the slow reply - it was a holiday here. Let's continue with what Josh said and I'll look at it when we do the UX review. Thanks!
Flags: needinfo?(msandberg)
Duplicate of this bug: 1217768
Hi Maria,
I think you mean Evelyn ;)

Just a soft reminder that you might want to check bug 1225081 and comment 17 from Luke.
Thanks!
Flags: needinfo?(msandberg)
Hi Josh,

I think we decided to look at comment 17 in the UX review phase. Thanks!
Flags: needinfo?(msandberg)
Verify this issue on the latest build.
The web apps can be opened directly when user press "ok" key and show up a preview window without any install confirmation. And user can press the “back” key to close the app when the web apps is opened.

[Build Info]
simulator 2.6.20160222133739
gaia:
https://github.com/mozilla-b2g/gaia/commit/d9faad5c0f14fcd42f920c9104f0638f46a48b2a
gecko:
https://hg.mozilla.org/mozilla-central/rev/789a12291942763bc1e3a89f97e0b82dc1c9d00b
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.