Closed Bug 1237606 Opened 5 years ago Closed 5 years ago

The reload addon use new toolbox files only once

Categories

(DevTools :: General, defect)

defect
Not set
normal

Tracking

(firefox46 fixed)

RESOLVED FIXED
Firefox 46
Tracking Status
firefox46 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

Details

Attachments

(1 file, 2 obsolete files)

When using the reload addon, only the first modification made to toolbox.js (and most likely other UI files) are not considered. Either firefox file or the first modification are considered.

It is most likely an issue with gDevTools keeping reference to old loader/instances.
Attached patch patch v1 (obsolete) — Splinter Review
This patch looks like a big workaround to not rewrite gDevTools right away.
But I suspect it will take some time to actually rewrite it.
This solves this bug as well as bug 1237208.
Comment on attachment 8705193 [details] [diff] [review]
patch v1

Review of attachment 8705193 [details] [diff] [review]:
-----------------------------------------------------------------

I started looking into splitting gDevTools and moving code to loader modules,
but that won't be easy and will certainly take time.

Do you think that's reasonable to add such trick in the meantime?
Attachment #8705193 - Flags: feedback?(jryans)
Comment on attachment 8705193 [details] [diff] [review]
patch v1

Review of attachment 8705193 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, I think this is fine for now.  It's pretty self-contained.

::: devtools/client/framework/gDevTools.jsm
@@ +11,5 @@
>  Cu.import("resource://gre/modules/XPCOMUtils.jsm");
>  Cu.import("resource://gre/modules/Services.jsm");
> +
> +let require, loader, promise, DefaultTools, DefaultThemes;
> +let loadDependencies = () => {

Add a comment here that this is not wonderful and we plan to do better by breaking up the module, etc.
Attachment #8705193 - Flags: feedback?(jryans) → feedback+
Attached patch patch v2 (obsolete) — Splinter Review
With a comment.
Attachment #8705193 - Attachment is obsolete: true
Attached patch patch v3Splinter Review
Note that I'm about to submit patches to bug 1188405.
So I won't let this thing live for long!
Attachment #8706877 - Flags: review?(jryans)
Attachment #8706606 - Attachment is obsolete: true
Assignee: nobody → poirot.alex
https://hg.mozilla.org/integration/fx-team/rev/b3e626983fe5cd35a8546086f519d683e0f3ddd9
Bug 1237606 - Ensure reloading gDevTools dependencies from the reload addon. r=jryans
https://hg.mozilla.org/mozilla-central/rev/b3e626983fe5
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
Duplicate of this bug: 1237208
[bugday-20160323]

Status: RESOLVED,FIXED -> UNVERIFIED

Comments:
STR: Not clear.
Developer specific testing

Component: 
Name			Firefox
Version			46.0b9
Build ID		20160322075646
Update Channel          beta
User Agent		Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
OS			Windows 7 SP1 x86_64

Expected Results: 
Developer specific testing

Actual Results: 
As expected
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.