Bookmarked entries should still show up in location bar suggestions even if they are AutoFilled

RESOLVED WONTFIX

Status

()

Firefox
Location Bar
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: Prasanna, Unassigned)

Tracking

43 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151223140742

Steps to reproduce:

1. Go to http://subscene.com/ and bookmark it.
2. Type "sub" in the location bar.


Actual results:

The "Visit http://subscene.com/" suggestion shows up but my bookmark is not there in the suggestions.


Expected results:

In addition to the "Visit ..." results, I should be seeing my actual bookmark also in the suggestions drop-down.

This was how autoFill was working prior to the unified complete in FF 43. AutoFill should not remove bookmarked entries even though they are identical. 

I guess most people would typically use autoFill to get to their un-bookmarked history, but would actually prefer going to the bookmark entry instead of the autoFill entry when they have bookmarked a website.
(Reporter)

Updated

2 years ago
Component: Untriaged → Location Bar
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Updated

2 years ago
Blocks: 995091
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Prasanna from comment #0)
> I guess most people would typically use autoFill to get to their
> un-bookmarked history, but would actually prefer going to the bookmark entry
> instead of the autoFill entry when they have bookmarked a website.

Based on what you think people may want to get multiple entries pointing to the same url? That just sounds like a waste of space.
(Reporter)

Comment 2

2 years ago
I believe it would be worth that one extra entry to show the bookmark even if it's identical to the autoFill. Bookmarks are so fundamental and hiding them for whatever reason may not be a good idea.

It is normal for people to bookmark a link inside a website instead of the website homepage. Say in this case I had bookmarked subscene.com/xyz instead of just subscene.com. But autoFill cannot get me to subscene.com/xyz, it only gets me to subscene.com.

Now when I start typing 'sub', if my bookmark doesn't show up, I can't say if it's because I haven't accessed the bookmark in a while or because if I had actually bookmarked only subscene.com and Firefox is hiding it cause autoFill already matched it. So previously I would continue typing the full website title until my bookmark eventually shows up. But now I can't be so sure as my bookmark would never show up if it's being intentionally hidden. I think this makes the whole experience a bit unreliable. (Probably a blue star (the usual bookmark logo) adjacent to the "Visit ..." showing if it's your bookmark or just plain history might also help.)

Plus I think the current setup is not very predictable anyway. If the website has a "www." in its URL then both "Visit ..." and the bookmark entry are shown. Also if the website is a https instead of http, again both "Visit ..." and the bookmark entry are shown.
(In reply to Prasanna from comment #2)
> It is normal for people to bookmark a link inside a website instead of the
> website homepage. Say in this case I had bookmarked subscene.com/xyz instead
> of just subscene.com. But autoFill cannot get me to subscene.com/xyz, it
> only gets me to subscene.com.

yes, but you should consider that without autofill suggesting subscene.com, your subscene.com/xyz bookmark would not appear.
The only duplicate removal that autocomplete does is when the urls are identical, so currently subscene.com should be autofill, but there should also be an entry for subscene.com/xyz (provided it has an high enough score)

> Now when I start typing 'sub', if my bookmark doesn't show up, I can't say
> if it's because I haven't accessed the bookmark in a while or because if I
> had actually bookmarked only subscene.com and Firefox is hiding it cause
> autoFill already matched it.

I'm not sure why that matters, if you bookmarked subscene.com and autofill suggests subscene.com, you get what you need regardless. Why does it matter if you didn't access it in a while?

> I think this makes the whole experience a bit unreliable. (Probably a blue
> star (the usual bookmark logo) adjacent to the "Visit ..." showing if it's
> your bookmark or just plain history might also help.)

Maybe, but we still plan some changes up there so I'd first wait to see where we end up. We don't want to clutter the UI with icons that may not be that useful.

> Plus I think the current setup is not very predictable anyway. If the
> website has a "www." in its URL then both "Visit ..." and the bookmark entry
> are shown. Also if the website is a https instead of http, again both "Visit
> ..." and the bookmark entry are shown.

That's because one of the entry has an https schema, the other one an http. I think we should somehow clarify that better. Unfortunately we can't undupe those because the 2 may point to 2 completely different websites (even if it would be dumb).
(Reporter)

Comment 4

2 years ago
> yes, but you should consider that without autofill suggesting subscene.com,
> your subscene.com/xyz bookmark would not appear.
> The only duplicate removal that autocomplete does is when the urls are
> identical, so currently subscene.com should be autofill, but there should
> also be an entry for subscene.com/xyz (provided it has an high enough score)

That clears up things. Thanks! 

Feel free to close this bug.
sure
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.