[DOGFOOD] Key Events aren't fielded at all.

VERIFIED FIXED in M12

Status

()

Core
Event Handling
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: David Hyatt, Assigned: joki (gone))

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] Fix expected by 11/24)

(Reporter)

Description

19 years ago
Open up mail/news (don't worry, you don't have to have an account set up to even
see this bug).  Double-click on the mailbox, which opens it up.  Now try hitting
the down arrow.

Current Behavior: Nothing happens.
Expected Behavior: You should see the second row selected.

The key event never seems to get to the frame.

The key event also never goes into the DOM.  To verify this, hit the ALT key
once you have one of the tree items (e.g., the mailbox) selected.  The expected
behavior is that the File menu on the menu bar should activate (this is done
through DOM capturing).  It never even gets the event.
(Reporter)

Comment 1

19 years ago
Ok, the ALT thing was my fault.  The frame level stuff still doesn't work
though.

Updated

19 years ago
Whiteboard: [PDT+]

Comment 2

19 years ago
Putting on PDT+ radar.

Updated

19 years ago
Blocks: 16950

Updated

19 years ago
Target Milestone: M12

Comment 3

19 years ago
Dogfood, putting on M12 radar.

Updated

19 years ago
Blocks: 18951
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: [PDT+] → [PDT+] Fix expected by 11/24
(Assignee)

Comment 4

19 years ago
I'm not sure if the bug is in the event model implementation or a bad
expectations of the behavior of the event model.  I'll look through and see what
I can find.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
This seems to be fixed now.  Works fine for me on NT, haven't tried other OS's

Updated

19 years ago
QA Contact: janc → ckritzer

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Marking VERIFIED FIXED on WinNT 1999112908 apprunner.
Also works on:
	Linux6 1999112908 apprunner
	MacOS86 1999112908 apprunner

Updated

18 years ago
No longer blocks: 18951
You need to log in before you can comment on or make changes to this bug.