Pop-up notifications still displayed when Block pop up (windows) option enabled

RESOLVED INVALID

Status

()

--
trivial
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: preethi.dhinesh, Unassigned)

Tracking

(Blocks: 1 bug, {uiwanted})

44 Branch
uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20160108])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8705934 [details]
bug2.mp4

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160107144911

Steps to reproduce:

1.Open https://pdehaan.github.io/push-notification-test/
2.Click the pop Notification button  and set the hanger to Always Receive Notifications 
3.Close the popup 
4.Go to and settings and click content and Check the box Block pop-up windows(about:preferences#content)
5.Return to https://pdehaan.github.io/push-notification-test/ and click the pop Notification button 
[testday-20160108]
 and click the pop Notification button 


Actual results:

The pop up dialog for the notification displays . 


Expected results:

The pop up dialog for the notification should  not be displayed.
(Reporter)

Updated

3 years ago
QA Whiteboard: [testday-20160108]
OS: Unspecified → Mac OS X
Whiteboard: [testday-20160108]
(Reporter)

Updated

3 years ago
Component: Untriaged → Preferences

Comment 1

3 years ago
This is not a pop-up (window), it is a (pop-up) Notification.

Any reasons to distinguish between them?
Severity: normal → trivial
OS: Mac OS X → Unspecified

Updated

3 years ago
Duplicate of this bug: 1238245

Comment 3

3 years ago
It may needs to improve the wording.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
Summary: pop up dialog box displays ever after checking the Block pop up windows → Pop-up notifications still displayed when Block pop up (windows) option enabled

Updated

3 years ago
Blocks: 1201571

Comment 4

3 years ago
Comment #1 is correct, pop up blocker is for new windows not web notifications.  You can disable them in Notifications > choose... remove or block
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.