Bookmarks and history not displayed (bookmarks manager, sidebar bookmarks and history window all appear empty)

RESOLVED DUPLICATE of bug 1237602

Status

defect
--
major
RESOLVED DUPLICATE of bug 1237602
4 years ago
4 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

({regression})

SeaMonkey Tracking Flags

(seamonkey2.42 unaffected, seamonkey2.43 affected)

Details

Last good:
UA:"Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0 SeaMonkey/2.43a1"
ID:20160107003001 en-US
c-c:3f5e39b93615b2efaa3f186180161ac9dabea392
m-c:1ec3a3ff68f2d1a54e6ed33e926c28fee286bdf1

First bad:
UA:"Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0 SeaMonkey/2.43a1"
ID:20160108003001 en-US
c-c:625d871a9669ee81da4b6128efc95301dae3f7cb
m-c:d4213241bb796fdfa7a5ad4f1989e97b44474364

Symptoms:
Both the Bookmarks Manager (Ctrl+B) and the Bookmarks Sidebar (F9, then if necessary select "Bookmarks" tab) are empty. The bookmarks are not lost, since going back to a "good" build shows them again.

Now I'm going to try a "bad" build in Safe Mode but I doubt that it will make a difference, I have no bookmarks-related extensions or userC*.css rules. I shall report any possibly relevant stdout/stderr messages at the same time.

May or may not be relevant: The regression range is the same as for bug 1237859 (a regression in "Add-on Manager - Version Number" extension caused by a change in Core or Toolkit) and bug 1238189 (a solid crash somewhere in MailNews when trying to access the W3C HTML5 standard in the SeaMonkey browser, but not in other browsers I have installed including Firefox 46.0a1 of the same build date).
I am now in a "bad" build started with -safe-mode on the command-line, and I have the same problem.

I use History much less often than Bookmarks but I notice that the history window is also empty. Now I'm going back to the "last good" build to check if it has "proper" history, but first, let's have a look at the log...

Nothing much, and irrelevant AFAICT. The datestamp is added to separate successive runs of SeaMonkey:

Sun 10 Jan 23:48:17 CET 2016

(seamonkey:9232): GLib-GObject-WARNING **: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

(seamonkey:9232): GLib-GObject-WARNING **: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version.
The last good build for bookmarks is also AFAICT the last good one for history.
Summary: Bookmarks not displayed (both bookmarks manager and sidebar bookmarks appear empty) → Bookmarks and history not displayed (bookmarks manager, sidebar bookmarks and history window all appear empty)
P.S. Even in the "bad" builds, the Bookmarks menu is OK.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1237602
You need to log in before you can comment on or make changes to this bug.