Re-run e10s A/B experiment on Beta 44

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Felipe, Assigned: Felipe)

Tracking

44 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

We should re-run the e10s A/B experiment on Beta 44 for the remainder of Beta. More precisely until Jan 26th according to Blassey in #e10s.

Also should make sure that the minbuildid includes bug 1236754.
I've checked that bug 1236754 made it to beta7, which has build id = 20160107144911

I'll do some sanity checks with the experiment on this build now
Summary: [meta] Run an e10s A/B experiment on Beta 44 → Re-run e10s A/B experiment on Beta 44
Should we get RyanVM's team, who took over QAing telemetry experiments, to take a quick look to make sure the experiment is still working as expected with these changes?

From the looks of bug # 1236754, the following prefs should be enabled when someone already has e10s enabled or is placed into the e10s experiment group correct?

>> extensions.interposition.enabled
>> extensions.interposition.prefetching
>> dom.compartment_per_addon
>> dom.ipc.plugins.asyncInit.enabled
New experiment patch. Only the add-on ID and manifest values (endDate, minBuildID) were changed.
Attachment #8707001 - Flags: review+
Posted file experiment.xpi
Hey Jason, could you sign this new experiment xpi?
Attachment #8707003 - Flags: feedback?(jthomas)
(In reply to Kamil Jozwiak [:kjozwiak] from comment #2)
> Should we get RyanVM's team, who took over QAing telemetry experiments, to
> take a quick look to make sure the experiment is still working as expected
> with these changes?
> 
> From the looks of bug # 1236754, the following prefs should be enabled when
> someone already has e10s enabled or is placed into the e10s experiment group
> correct?
> 
> >> extensions.interposition.enabled
> >> extensions.interposition.prefetching
> >> dom.compartment_per_addon
> >> dom.ipc.plugins.asyncInit.enabled

Yeah that would be nice. When we get the signed xpi I'll push the new experiment to the staging server for some testing
Signed experiment.xpi
Attachment #8707003 - Flags: feedback?(jthomas) → feedback+
> Yeah that would be nice. When we get the signed xpi I'll push the new
> experiment to the staging server for some testing

RyanVM, would your team be able to look at this once everything is ready? I can provide you with the test cases I originally used when we launched this experiment.
Flags: needinfo?(ryanvm)
Pushed https://hg.mozilla.org/webtools/telemetry-experiment-server/rev/ab54b1891657

In some moments the new experiment should appear alongside the URLBar experiment at the staging server https://telemetry-experiment-dev.allizom.org/

Comment 9

3 years ago
I can confirm extensions.interposition.enabled(workaround) kicks in now on beta.
CanvasBlocker add-on giving 30s hangs (most prolific I have experienced.) Bug 1196975 breaks the add-on in 45.
Flags: needinfo?(ryanvm)
Felipe, as per the decision on email, we have decided to postpone this experiment to the start of Beta45 cycle. Beta8 - RC week does not seem like the place to start any experiments especially if it requires code changes to the binaries we ship (pref changes in this case). Could you revert the changes that were made? Thanks!
Flags: needinfo?(felipc)
Backed out the experiment in https://hg.mozilla.org/webtools/telemetry-experiment-server/rev/7b8a1908c85e

I believe the prefs do not need to be backed out because they won't affect non-e10s, but I'll let that be figured out in bug 1238802.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(felipc)
Resolution: --- → WONTFIX
(In reply to :Felipe Gomes (needinfo me!) from comment #11)
> I believe the prefs do not need to be backed out because they won't affect
> non-e10s, but I'll let that be figured out in bug 1238802.

I mean bug 1236754
(Is this resolved wontfix (wontdo?)

If you want heartbeat or other survey stuff, come talk to us :)
)
You need to log in before you can comment on or make changes to this bug.