[meta] tracking: e10s beta experiment crash rates

RESOLVED DUPLICATE of bug 1249209

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1249209
a year ago
a year ago

People

(Reporter: jimm, Unassigned)

Tracking

(Depends on: 1 bug, {meta})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox46 affected)

Details

(Reporter)

Description

a year ago
Currently we're running about 21% higher crash rates under e10s.

control:
https://crash-stats.mozilla.com/search/?product=Firefox&ActiveExperiment=%3De10s-enabled-beta-20151214%40experiments.mozilla.org&date=%3E%3D2015-12-18&ActiveExperimentBranch=%3Dcontrol&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#crash-reports

experiment:
https://crash-stats.mozilla.com/search/?product=Firefox&ActiveExperiment=%3De10s-enabled-beta-20151214%40experiments.mozilla.org&date=%3E%3D2015-12-18&ActiveExperimentBranch=%3Dexperiment&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#crash-reports
This is by pure volume.  Do we have a way to correlate this to ADI under each test group?
(Reporter)

Comment 2

a year ago
(In reply to [:tracy] Tracy Walker - QA Mentor from comment #1)
> This is by pure volume.  Do we have a way to correlate this to ADI under
> each test group?

yep - 
https://bsmedberg.github.io/telemetry-experiments-dashboard/

currently:

<jimm> experiment 496714 40%
<jimm> control 482320 39%
(Reporter)

Comment 3

a year ago
killhard abort signature report:
http://www.mathies.com/mozilla/client-abort-report-beta.txt
Keywords: meta
(Reporter)

Updated

a year ago
Depends on: 1158189, 1140115
(Reporter)

Updated

a year ago
Blocks: 1218484
(Reporter)

Updated

a year ago
Depends on: 1107792
(Reporter)

Updated

a year ago
tracking-e10s: --- → ?
Depends on: 1235633
Depends on: 1198765, 1145613
No longer depends on: 1235633
Depends on: 1235633
Summary: tracking: e10s beta experiment crash rates → [meta] tracking: e10s beta experiment crash rates
(Reporter)

Updated

a year ago
Depends on: 1222890
Depends on: 1236108

Comment 4

a year ago
Links for beta4+

control:
https://crash-stats.mozilla.com/search/?product=Firefox&ActiveExperiment=%3De10s-enabled-beta-20151214%40experiments.mozilla.org&date=%3E%3D2015-12-29&ActiveExperimentBranch=%3Dcontrol&build_id=%3E%3D20151228134903&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#crash-reports

experiment:
https://crash-stats.mozilla.com/search/?product=Firefox&ActiveExperiment=%3De10s-enabled-beta-20151214%40experiments.mozilla.org&date=%3E%3D2015-12-29&ActiveExperimentBranch=%3Dexperiment&build_id=%3E%3D20151228134903&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#crash-reports


Prior rank #1 (OOM | unknown | NS_ABORT_OOM | gfxContext::PushNewDT) gone. Bug 1107792

Prior rank #2 (std::_Atomic_fetch_add_4) Bug 1225829. Still around. Occurrence has been roughly halved.

Comment 5

a year ago
There is a significant difference (main v content) in crash submit success.

Link for complete beta population not just experiment
https://telemetry.mozilla.org/new-pipeline/dist.html#!compare=e10sEnabled&cumulative=0&end_date=2016-01-01&keys=main-crash!plugin-crash!plugin-hang!content-crash&max_channel_version=beta%252F44&measure=PROCESS_CRASH_SUBMIT_SUCCESS&min_channel_version=null&processType=false&product=Firefox&sanitize=1&sort_keys=submissions&start_date=2015-12-19&table=0&trim=1&use_submission_date=1
tracking-e10s: ? → +
Depends on: 1238802
(Reporter)

Updated

a year ago
No longer depends on: 1158189

Updated

a year ago
Depends on: 1241106
Depends on: 1243112

Comment 6

a year ago
Links for beta 45 with add-ons experiment.

control:
https://crash-stats.mozilla.com/search/?product=Firefox&release_channel=beta&ActiveExperiment=%3De10s-beta45-withaddons%40experiments.mozilla.org&ActiveExperimentBranch=%3Dexperiment&date=%3E%3D2016-01-29&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#crash-reports

experiment:
https://crash-stats.mozilla.com/search/?product=Firefox&release_channel=beta&ActiveExperiment=%3De10s-beta45-withaddons%40experiments.mozilla.org&ActiveExperimentBranch=%3Dexperiment&date=%3E%3D2016-01-29&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#crash-reports

Hard hitting Bug 1210099 new since 44, Possibly causing users to quit, percentage has decreased since start.
Two other new top signatures also stand out, not sure if related so will let someone more experience decide whether to create bugs.
Depends on: 1210099

Updated

a year ago
Depends on: 1257486
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1249209
You need to log in before you can comment on or make changes to this bug.