Bug 123907 (overwrite)

Do not warn for directory not existing, but the opposite

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
18 years ago
11 years ago

People

(Reporter: jmd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Every software installer I've ever used has had the stupidest feature I've ever
seen. They warn when you choose a directory to install to that DOESN'T exsist.
This is awful. Of course it doesn't exsist. It's normal for it not to exsist. In
fact, it's GOOD for it not to exsist.

If it DOES exsist, THEN we have a problem. THEN we need the warning dialog.

Please stop annoying users with the 'directory /foo does not exsist, create it?'
dialog. We should be more concerned about the opposite, where files may be
overwriten, or where a Mozilla install could be intermingled with other types of
files and hard to remove on platforms without a installation registry (UNIX...).
Status: NEW → ASSIGNED
QA Contact: bugzilla → ktrina
Summary: Do not warn for directory not exsisting, but the opposite → Do not warn for directory not existing, but the opposite
perhaps this is OS = All... ?
OS: Linux → All
*** Bug 193919 has been marked as a duplicate of this bug. ***
Alias: overwrite
also this warning must say, that a version already installed must be deleted
before installing the new one.
*** Bug 207761 has been marked as a duplicate of this bug. ***
We should probably go farther and show them the contents of the directory that
they are going to be installing it into, and put a checkbox on the dialog to
make sure they didn't just impulsively click yes, as follows:

+-----------------------------------------------+
| C:\ already exists and contains the following |
| contents:                                     |
| +-------------------------------------------+ |
| |  C:\Mozilla                               | |
| |  |__ chrome                               | |
| |  |__ plugins                              | |
| +-------------------------------------------+ |
| Installing Mozilla into that directory could  |
| overwrite files and a later uninstall could   |
| erase important files and directories!!!      |
|                                               |
| [ ] I am aware that I could overwrite files   |
|     and lose important data.                  |
|                                               |
| Are you sure you want to install in this      |
| location?                                     |
|             [Yes] [[No]]                      |
+-----------------------------------------------+

If the directory already exists, the files in it should not be deleted but moved
to C:\that_directory\backup

We should not allow people to install into system directories such as Program
Files or Windows (which my mom did in 2002)

See also bug 233625 on the results of installing into a directory that exists
with the Firefox installer (different installer).
Product: Browser → Seamonkey
Assignee: dveditz → nobody
Status: ASSIGNED → NEW
QA Contact: ktrina → general
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.